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DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY
ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN LIFE 
SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS PRIOR WRITTEN APPROVAL OF 
THE PRESIDENT AND GENERAL COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for 
use provided in the labeling can be reasonably expected to result in a significant injury to the user. A criti-
cal component is any component in a life support device or system whose failure to perform can be reason-
ably expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2016 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, 
or technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES 
NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED 
IN ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been verified according 
to the general principles of electrical and mechanical engineering. 

S3 and Z8 are trademarks or registered trademarks of Zilog, Inc. All other product or service names are the 
property of their respective owners.

Warning:
UM027402-0816 Disclaimer
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Each instance in this document’s revision history reflects a change from its previous edi-
tion. To learn more, refer to the corresponding page(s) or appropriate links furnished in the 
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Overview
Zilog’s S3F8S28 Development Kit, part number S3F8S280100ZCOG, allows you to eval-
uate your S3F8S28-based designs and applications. The Kit features a Development 
Board consisting of the following components: 

• Four LEDs 

• Two pushbuttons 

• UART

• Header Pins 

This user manual provides instructions for setting up and configuring the S3F8S28 Devel-
opment Board. It includes schematic diagrams and a discussion of the Board features and 
ZDS II.

The S3F8S28 Development Board features an S3F8S28 MCU in a 24-pin SOP package, 
plus an S3 PGM connector to connect the Board to a host development PC using the S3 
Flash In-System Programmer (ISP) II. To learn more about the S3F8S28 MCU, refer to 
the S3F8S28 Product Specification (PS0313) and/or the S3 Flash In-System Programmer 
User Manual (UM0266). 

This document guides you through the following tasks:

• Downloading and installing ZDS II software and documentation 

• Connecting the S3 Flash ISP II and S3F8S28 Development Board to your PC

• Starting the S3F8S28 Ledblink sample program 

Kit Contents
The S3F8S28 Development Kit contains the following items:

• S3F8S28 Development Board

• S3 Flash ISP II

• 10-circuit ribbon cable

• USB A (male) to Mini-B USB cable (2)

• S3F8S28 Development Kit hardcopy insert
UM027401-0715 Overview
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Figure 1 shows the contents of the S3F8S28 Development Kit.

Features
The S3F8S28 Development Kit includes the following key items.

• S3F8S28 Development Board, which contains the following features:
– S3F8S28 24-pin SOP MCU operating at 12 MHz, with 8 KB of internal Flash 

memory and 2 KB of internal RAM memory 
– USB interface to supply power to the board
– UART header at J8
– Test Points header for all pins of MCU
– MCU current measurement Test Points J1-1 and J1-2
– ADC4/P0.4 adjustable input voltage (using potentiometer R8) 

• S3 Flash In-System Programmer II

• ZDS II software, samples, and documentation available free for download
– Sample programs

Figure 1. The S3F8S28 Development Kit
UM027401-0715 Features
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Supported Host Environments
The S3F8S28 Development Board supports the following operating systems:

• Microsoft Windows 7 (32-bit/64-bit) 

• Microsoft Windows 8 (32-bit/64-bit) 

Install the ZDS II Software and Documentation
Observe the following steps to download and install your ZDS II software and documenta-
tion.

If you have already installed ZDS II – S3 <version> and have downloaded the software 
and documentation by following the procedure on the paper insert in your kit (FL0172), 
skip ahead to the next section.

1. Prior to connecting the S3F8S28 Development Board to your development PC, 
download ZDS II for S3 v5.3.0 (or later) from the Downloadable Software category in 
the Zilog Store.

2. When the download is complete, unzip the file to your hard drive, then double-click 
the installation file named ZDS2_S3_<Version>.exe and follow the on-screen 
instructions. 

3. When the ZDS II installation is complete, double-click the installation file named 
DOCS_S3<version>.exe and follow the on-screen instructions. 

4. When these installations are complete, view the S3F8S28 Development Kit User 
Manual (UM0274); this document will be located in the following path, by default: 
C:\Zilog\ZDSII_ S3 _<version>\Documentation\Tools_Documentation

Establish a Connection with the PC
Observe the following procedure to connect the S3 Flash ISP  II and the S3F8S28 Devel-
opment Board to your PC.

Note:
UM027401-0715 Supported Host Environments
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Disconnect or turn off the power to the S3F8S28 Development Board before connecting 
or disconnecting the S3 Flash ISP  II.

1. Connect the Mini-B side of the USB A (male)-to-Mini-B cable to the S3 Flash ISP  II. 
Connect the other end of this cable to the PC, as shown in Figure 2.

2. Connect the 10p 5x2 ribbon cable to the S3 Flash ISP  II, as shown in Figure 3.

3. Connect the other end of the ribbon cable to Jumper J4/J5 on the Development Board. 
Ensure that Pin 1 on the ribbon cable is aligned with Pin 1 on the target connector, as 
indicated in Figure 4.

Figure 2. Connecting the S3 Flash ISP  II to the Development PC

Figure 3. Connecting the 10-pin Ribbon Cable to the S3 Flash ISP  II

Caution:
UM027401-0715 Establish a Connection with the PC
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Ensure that you connect the 10 pin ribbon cable using the correct orientation to prevent 
damage to the S3 Flash ISP  II.

4. After completing the procedure to connect the S3F8S28 Development Board to the 
PC, the complete setup appears as shown in Figure 5.

Figure 4. Debug Connectors J4 and J5

Figure 5. The Completed ISP II and Development Board Assembly

Caution:
UM027401-0715 Establish a Connection with the PC
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Start the S3F8S28 Ledblink Sample Program
The S3F8S28 Development Kit includes a sample program that demonstrates an LED 
blinking application. To start the S3F8S28 Ledblink sample program, observe the follow-
ing procedure.

1. Launch ZDS II by navigating from the Windows Start menu to Programs → Zilog 
ZDS II – S3 <Version> → ZDS II – S3 <Version>.

2. From the File menu in ZDS II, select Open Project as indicated in Figure 6, and navi-
gate to the following filepath:

<ZDS Install>\samples\S3F8S28\ledblink_asm

3. Select the ledblink.zdsproj project from within the ledblink_asm folder as 
indicated in Figure 7 and click Open. A list of source files will appear in the Work-
space panel.

Figure 6. The Open Project Selection in the File Menu
UM027401-0715 Start the S3F8S28 Ledblink Sample Program
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4. From the Build menu, select Set Active Configuration to open the Select Configura-
tion dialog box.

5. Select Debug, then click OK to close the Select Configuration dialog box.

6. From the Project menu in ZDS II, select Settings to open the Project Settings dialog 
box. In the Project Settings dialog box, click the Debugger tab.

Figure 7. Select the ledblink.zdsproj Project
UM027401-0715 Start the S3F8S28 Ledblink Sample Program
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7. On the Debugger page, select S3F8S2X_FlashIspII from the Target list, then select 
S3FlashIspII from the Debug Tool drop-down menu, as indicated in Figure 8.

Figure 8. Select the Target and Debug Tool
UM027401-0715 Start the S3F8S28 Ledblink Sample Program
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8. After selecting S3FlashIspII from the Debug Tool drop-down menu, click Setup to 
select the serial number of the S3 Flash ISP II you are using, as indicated in Figure 9.
Click OK to close the Setup USB Comunication dialog box.

The serial number you see on your screen will be different from the serial number shown 
in Figure 9.

9. After selecting the serial number of the S3 Flash ISP II that you are using, select 
Setup from the Target field to select the Target Voltage. 

10. From the Target Configuration dialog, enter “0” on ISP_DBG_IDX and select the 
3.3V by ISP button and Click OK. See Figure 10. 

Figure 9. The Setup USB Communication Dialog

Note:
UM027401-0715 Start the S3F8S28 Ledblink Sample Program
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11. Make sure that the Enhanced ISP Debug Library is selected fom the Debugger win-
dow.

12. Click OK to close the Project Settings dialog box.

13. If you are prompted to rebuild any affected files, click Yes. Otherwise, choose Build
from the menu bar, then click Rebuild All. The following example message is dis-
played.

OUTPUT CHECKSUM
ledblink.hex B4D5
ledblink.lod B4D5

0 warning(s) 
0 error(s) 
Build succeeded.

This Output Checksum message is an example and may not match the actual checksum of 
the project for a particular release of the ZDS installation software.

Figure 10. The Target Configuration Dialog

Note:
UM027401-0715 Start the S3F8S28 Ledblink Sample Program
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At this point, before executing a Reset+Go on the next step, the mini USB on P1 is dis-
connected.

14. To run the application, select Reset+Go from the Debug menu, as indicated in 
Figure 11. As a result, power LED1 will light up. LED2, LED3, and LED4 will blink 
in sequence.

Troubleshooting Tips
The following troubleshooting tips are useful when starting the S3F8S28 Ledblink sample 
program.

• LED PWR indicator on the S3 Flash ISP II lights up when in debug mode and J1 is 
shunted.

• Navigate to Project → Settings → Debugger → Debug Tool → Setup. Upon click-
ing Setup on the Setup USB Communication dialog box, verify that S3FlashIspII is 
displayed.

Figure 11. Select Reset+ Go from the Debug Menu

Note:
UM027401-0715 Troubleshooting Tips
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• Remove and reconnect the ISP II on the USB port of your PC.

• Refer to Figure 14 on page 13 to learn more about the operations and power options of 
the S3F8S28 Development Board.

S3F8S28 Development Board
The purpose of the S3F8S28 Development Kit is to provide a set of hardware and software 
tools for the development of hardware and firmware for applications based on the 
S3F8S28 microcontroller. An image of the S3F8S28 Development Board is shown in 
Figure 12; a block diagram is shown in Figure 13.

Figure 12. The S3F8S28 Development Board

Figure 13. The S3F8S28 Development Board Block Diagram

S3F8S28USB

LED (G,Y,R) TEST HEADERS
PUSHBUTTON

UART
CONNECTOR

ISP
CONNECTOR

VDD=5V
UM027401-0715 S3F8S28 Development Board



S3F8S28 Development Kit
User Manual

13
Operations and Power Options
The operations and power options of the S3F8S28 Development Board are listed in 
Figure 14.

S3F8S28 MCU
Key features of the S3F8S28 MCU include: 

• SAM88RC CPU core 

• 8 K x 8 bits program memory

• Endurance: 10,000 Erase/Program cycles

• 78 instructions

• Three I/O ports (maximum 22 pins)

• 8 interrupt levels and 17 interrupt sources (8 external interrupt and 9 internal interrupt)

• One 16-bit timer(Timer 0) or two 8-bit timers A/B with time interval mode

• Thirteen analog input pins (maximum)

• 12-bit conversion resolution

• Support serial data transmit/receive operations with 8-bit, 9-bit UART 

Figure 14. Operations and Power Options of the S3F8S28 Development Board
UM027401-0715 Operations and Power Options
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To learn more about the S3F8S28 MCU, refer to the S3F8S28 Product Specification 
(PS0313).

Reset Circuit
The reset circuit features a 49.9 KΩ pull-up resistor R4 and SW1. This circuit resets the 
S3F8S28 MCU when SW1 is pressed. See Figure 15 for a representation of the reset cir-
cuit.

Figure 15. The Reset Circuit
UM027401-0715 Reset Circuit

: http://www.zilog.com/docs/PS0313.pdf
: http://www.zilog.com/docs/PS0312.pdf
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ISP II Connector

The ISP II connector (J4/J5) provides an interface between the S3 Flash ISP II tool and the 
S3F8S28 device. See Figure 16 for an illustration of the ISP  II connector.

Figure 16. The ISP II Connector
UM027401-0715 ISP II Connector
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ZDS Flash Loader Utility
A Flash Loader utility is included in Zilog Developer Studio II via the Tools menu. 
Figure 17 shows an image of the Flash Programming screen.

You can program the S3F8S28 MCU directly using the hex code generated from the ZDS 
IDE tools.

Figure 17. The Flash Programming Screen
UM027401-0715 ZDS Flash Loader Utility
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S3F8S28 Development Kit Documentation
The documents associated with the S3F8S28 Development Kit are listed in Table 1. Each 
of these documents can be obtained from the Zilog website by clicking the link associated 
with its Document Number. Alternatively, navigate to the directory listed in the Location 
column in your installed application.

S3F8S28 Sample Projects
Table 2 lists the sample projects developed for this application. Follow the filepath stated 
in the Location column to access the associated project.

Table 1. S3F8S28 Development Kit Documentation

Document Description Location
UM0274 S3F8S28 Development Kit User Manual Documentation\Tools_Documentation
PS0313 S3F8S28 Product Specification Documentation\Chip_Documentation
UM0266 S3 Flash In-System Programmer User Manual Documentation\Tools_Documentation
FL0172 S3F8S280100ZCOG Development Kit Insert Documentation\Tools_Documentation
FL0165 S3 Flash In-System Programmer Insert Documentation\Tools_Documentation
Online Help ZDS II-S3 IDE, Assembler and C Compiler On-Line 

Help
ZDS II-S3 >Help >Help Topics

Table 2. S3F8S28 Sample Projects

Project Location
ledblink samples\ledblink_asm 
ledblink samples\ledblink_c
S28_Demo samples\ISP_BL_Demo 
UM027401-0715 S3F8S28 Development Kit Documentation

http://www.zilog.com/docs/devtools/UM0266.pdf
http://www.zilog.com/docs/devtools/UM0274.pdf
http://www.zilog.com/docs/PS0313.pdf
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ndix A. Schematic Diagram
Figure 18 presents a schematic diagram of the S3F8S28 Development Board.

Figure 18. S3F8S19 Development Board Schematic Diagram
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Customer Support
To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at http:/
support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base or consider par-
ticipating in the Zilog Forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com/
UM027401-0715 Customer Support
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