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DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY
ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN LIFE 
SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS PRIOR WRITTEN APPROVAL OF 
THE PRESIDENT AND GENERAL COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for 
use provided in the labeling can be reasonably expected to result in a significant injury to the user. A criti-
cal component is any component in a life support device or system whose failure to perform can be reason-
ably expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2016 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, 
or technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES 
NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED 
IN ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been verified according 
to the general principles of electrical and mechanical engineering. 

S3 and Z8 are trademarks or registered trademarks of Zilog, Inc. All other product or service names are the 
property of their respective owners.

Warning:
UM027302-0816 Disclaimer
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Revision History
Each instance in this document’s revision history reflects a change from its previous edi-
tion. To learn more, refer to the corresponding page(s) or appropriate links furnished in the 
table below.
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Overview
Zilog’s S3F8S8B Development Kit, part number S3F8S8B0100ZCOG, allows you to eval-
uate your S3F8S8B-based designs and applications. The Kit features a Development 
Board consisting of the following components: 

• Four LEDs 

• Seventeen pushbuttons 

• Speaker 

• LCD module 

• UART

• 256 byte Serial EEPROM

• Header Pins 

This user manual provides instructions for setting up and configuring the S3F8S8B Devel-
opment Board. It includes schematic diagrams and a discussion of the Board features and 
ZDS II.

The S3F8S8B Development Board features an S3F8S8B MCU in a 100-pin TQFP pack-
age, plus an S3 PGM connector to connect the Board to a host development PC using the 
S3 Flash In-System Programmer II (ISP  II). To learn more about the S3F8S8B MCU, 
refer to the S3F8S8B Product Specification (PS0326) and/or the S3 Flash In-System Pro-
grammer User Manual (UM0266).

This document guides you through the following tasks:

• Downloading and installing ZDS II software and documentation 

• Connecting the S3 Flash ISP II and S3F8S8B Development Board to your PC

• Starting the S3F8S8B Ledblink sample program 

Kit Contents
The S3F8S8B Development Kit contains the following items:

• S3F8S8B Development Board

• S3 Flash ISP II

• 10-circuit ribbon cable

• USB A (male) to Mini-B USB cable (2)
UM027302-0816 Overview
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• S3F8S8B Development Kit hardcopy insert

Figure 1 shows the contents of the S3F8S8B Development Kit.

Features
The S3F8S8B Development Kit includes the following key items.

• S3F8S8B Development Board, which contains the following features:
– S3F8S8B 100-pin TQFP MCU operating at 12 MHz, with 64 KB of internal Flash 

memory and 2 KB of internal RAM memory 
– USB interface to supply power to the board
– LCD module
– Speaker
– 256 byte Serial EEPROM
– UART Header at J6
– Test Points Headers for all pins of MCU
– MCU current measurement Test Points J2 and J3
– Pin P47/AD7 level adjustable with potentiometer R11
– Push Buttons 

• S3 Flash In-System Programmer II (S3 Flash ISP II)

Figure 1. S3F8S8B Development Kit
UM027302-0816 Features



S3F8S8B Development Kit
User Manual

3

• ZDS II software, samples, and documentation available free for download
– Sample programs

Supported Host Environments
The S3F8S8B Development Board supports the following operating systems:

• Microsoft Windows 7 (32-bit/64-bit)

• Microsoft Windows 8 (32-bit/64-bit) 

Install the ZDS II Software and Documentation
Observe the following steps to download and install your ZDS II software and documenta-
tion.

If you have already installed ZDS II – S3 <version> and have downloaded the software 
and documentation by following the procedure on the paper insert in your kit (FL0171), 
skip ahead to the next section.

1. Prior to connecting the S3F8S8B Development Board to your development PC, 
download ZDS II for S3 v5.3.0 (or later) from the Downloadable Software category in 
the Zilog Store. 

2. When the download is complete, unzip the file to your hard drive, then double-click 
the installation file named ZDS2_S3_<Version>.exe and follow the on-screen 
instructions.

3. When the ZDS II installation is complete, double-click the installation file named 
DOCS_S3<version>.exe and follow the on-screen instructions.

4. When these installations are complete, view the S3F8S8B Development Kit User 
Manual (UM0273); this document will be located in the following path, by default: 
C:\Zilog\ZDSII_ S3 _<version>\Documentation\Tools_Documentation 

Establish a Connection with the PC
Observe the following procedure to connect the S3 Flash ISP  II and S3F8S8B Develop-
ment Board to your PC.

Note:
UM027302-0816 Supported Host Environments
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Disconnect or turn off the power to the S3F8S8B Development Board before connecting 
or disconnecting the S3 Flash ISP II.

1. Connect the Mini-B side of the USB A (male)-to-Mini-B cable to the S3 Flash ISP II. 
Connect the other end of this cable to the PC, as shown in Figure 2.

2. Connect the 10p 5x2 ribbon cable to the S3 Flash ISP II, as shown in Figure 3.

3. Connect the other end of the ribbon cable to Debug Connector J1 on the Development 
Board. See Figure 4.

Figure 2. Connecting the S3 Flash ISP II to the Development PC

Figure 3. Connecting the 10-pin Ribbon Cable to the S3 Flash ISP II

Caution:
UM027302-0816 Establish a Connection with the PC
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4. After completing the procedure to connect the S3F8S8B Development Board to the 
PC, the complete setup appears as shown in Figure 5.

Figure 4. Debug Connector J1

Figure 5. The Completed ISP II and Development Board Assembly
UM027302-0816 Establish a Connection with the PC
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Start the S3F8S8B Ledblink Sample Program
The S3F8S8B Development Kit includes a sample program that demonstrates an LED 
blinking application. To start the S3F8S8B Ledblink sample program, observe the follow-
ing procedure.

1. Launch ZDS II by navigating from the Windows Start menu to Programs → Zilog 
ZDS II – S3 <Version> → ZDS II – S3 <Version>.

2. From the File menu in ZDS II, select Open Project as indicated in Figure 6, and navi-
gate to the following filepath:

<ZDS Install>\samples\S3F8S8B\ledblink_asm

3. Select the ledblink.zdsproj project from within the ledblink_asm folder as 
indicated in Figure 7 and click Open. A list of source files will appear in the Work-
space panel.

Figure 6. The Open Project Selection in the File Menu
UM027302-0816 Start the S3F8S8B Ledblink Sample Program
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4. From the Build menu, select Set Active Configuration to open the Select Configura-
tion dialog box.

5. Select Debug, then click OK to close the Select Configuration dialog box.

6. From the Project menu in ZDS II, select Settings to open the Project Settings dialog 
box. In the Project Settings dialog box, click the Debugger tab.

Figure 7. Select the ledblink.zdsproj Project
UM027302-0816 Start the S3F8S8B Ledblink Sample Program
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7. On the Debugger page, select S3F8SXB_FlashIspII from the Target list, then select 
S3FlashIspII from the Debug Tool drop-down menu, as indicated in Figure 8.

Figure 8. Select the Target and Debug Tool
UM027302-0816 Start the S3F8S8B Ledblink Sample Program
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8. After selecting S3FlashIspII from the Debug Tool drop-down menu, click Setup to 
select the serial number of the S3 Flash ISP II you are using, as indicated in Figure 9.
Click OK to close the Setup USB Communicationdialog box.

The serial number you see on your screen will be different from the serial number shown 
in Figure 9.

9. After selecting the serial number of the  S3 Flash ISP II that you are using, select 
Setup from the Target field to select the Target Voltage..

10. From the Target Configuration dialog, enter “0” on ISP_DBG_IDX and select the
3.3V by ISP button and Click OK. See Figure 10.

Figure 9. The Setup USB Communication Dialog

Figure 10. Target Configuration Dialog

Note:
UM027302-0816 Start the S3F8S8B Ledblink Sample Program
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11. Make sure that the Enhanced ISP Debug Library is selcted fom the Debugger win-
dow

12. Click OK to close the Project Settings dialog box.

13. If you are prompted to rebuild any affected files, click Yes. Otherwise, choose Build
from the menu bar, then click Rebuild All. The following example message is dis-
played.

OUTPUT CHECKSUM
===============
ledblink.hex E332 
ledblink.lod E332

0 warning(s) 
0 error(s)
Build succeeded.

This Output Checksum message is an example and may not match the actual checksum of 
the project for a particular release of the ZDS installation software.

14. To run the application, select Reset+Go from the Debug menu, as indicated in 
Figure 11. As a result, LEDs D2, D3, and D4 will blink in sequence.

Figure 11. Select Reset+ Go from the Debug Menu

Note:
UM027302-0816 Start the S3F8S8B Ledblink Sample Program
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Troubleshooting Tips
The following troubleshooting tips are useful when starting the S3F8S8B Ledblink sample 
program.

• Ensure that the LED D4/POWER indicator on the S3 Flash ISP  II lights up upon con-
necting to the USB port of your PC.

• Navigate to Project → Settings → Debugger → Debug Tool → Setup. Upon click-
ing Setup on the Setup USB Communication dialog box, verify that S3FlashIspII serial 
number is displayed.

• Remove and reconnect the S3 Flash ISP II on the USB port of your PC.

• Refer to Figure 14 on page 13 to learn more about the operations and power options of 
the S3F8S8B Development Board.

S3F8S8B Development Board
The purpose of the S3F8S8B Development Kit is to provide a set of hardware and soft-
ware tools for the development of hardware and firmware for applications based on the 
S3F8S8B microcontroller. An image of the S3F8S8B Development Board is shown in 
Figure 12; a block diagram is shown in Figure 13.

Figure 12. The S3F8S8B Development Board
UM027302-0816 Troubleshooting Tips
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Figure 13. The S3F8S8B Development Board Block Diagram

S3F8S8BUSB

AUDIO LCD (8 x 7)
LED (G,Y,R)

KEYPAD
4x4 TEST HEADERSUART

CONNECTOR SPI

ISP
CONNECTOR

VDD=5V
UM027302-0816 S3F8S8B Development Board
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Operations and Power Options
The operations and power options of the S3F8S8B Development Board are listed in Figure 
14.

S3F8S8B MCU
Key features of the S3F8S8B MCU include:

• SAM88RC CPU core 

• 64K x 8 bits program memory

• 2,134 × 8 bits data memory 

• Endurance: 10,000 Erase/Program cycles

• 78 instructions

• Twelve programmable I/O ports, including eleven 8-bit ports, and one 2-bit port, for a 
total of 90 pins

• Sixteen bit-programmable pins for external interrupts

• One 8-bit basic timer for oscillation stabilization and watchdog functions (system r set)

• Four 8-bit timer/counter and two 16-bit timer/counter with selectable operating modes

• Watch timer for real time

• LCD Controller/driver

• A/D converter with 8 selectable input pins

Figure 14. Operations and Power Options of the S3F8S8B Development Board
UM027302-0816 Operations and Power Options
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• D/A converter with 1 selectable output pin

• Synchronous SIO modules

• Two asynchronous UART modules

• External data memory

• Battery level detector

• Pattern generation module  

To learn more about the S3F8S8B MCU, refer to the S3F8S8B Product Specification 
(PS0326).

Magnetic Speaker
The CVS-1508 Speaker (SP1) manufactured by CUI Inc. is rated at a frequency of 
1700 Hz. An image of the CVS-1508 device is shown in Figure 15.

This speaker is activated by removing the shunt on J7.

To learn more about the CVS-1508 device, visit http://www.cui.com/product/resource/
cvs-1508.pdf.

Figure 15. Magnetic Speaker
UM027302-0816 Magnetic Speaker
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Reset Circuit
The reset circuit features a 100 KΩ pull-up resistor R3 and SW1. This circuit resets the 
S3F8S8B MCU when SW1 is pressed. See Figure 16 for a representation of the reset cir-
cuit.

ISP II Connector
The ISP connector (J1) provides an interface between the S3 Flash ISP II tool and the 
S3F8S8B device. See Figure 17 for an illustration of the ISP connector.

Figure 16. The Reset Circuit

Figure 17. The ISP II Connector
UM027302-0816 Reset Circuit
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LCD
The VIM-878-DP-FC-S-LV LCD manufactured by Varitronix Ltd. is a 36-pin module 
seated on both J4 and J5. Figure 18 shows an image of this LCD.

This eight-digit LCD is activated by selecting the segment of each digit that must light up. 
Figure 19 shows the LCD pin configuration and assignments.

Figure 18. LCD

Figure 19. LCD Pin Configuration and Assignments
UM027302-0816 LCD
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Serial EEPROM
The 93C56B is enabled through the Chip Select pin (CS) and accessed via a 3-wire serial 
interface consisting of Data Input (DI), Data Output (DO), and Shift Clock (SK). Upon 
receiving a Read instruction at DI, the address is decoded, and the data is clocked out seri-
ally on the DO pin. Figure 20 shows the Serial EEPROM schematics.

Figure 20. Serial EEPROM Schematic
UM027302-0816 Serial EEPROM



S3F8S8B Development Kit
User Manual

18
ZDS Flash Loader Utility
A Flash Loader utility is included in Zilog Developer Studio II via the Tools menu. 
Figure 21 shows an image of the Flash Programming screen.

You can program the S3F8S8B MCU directly using the hex code generated from the ZDS 
IDE tools.

Figure 21. The Flash Programming Screen
UM027302-0816 ZDS Flash Loader Utility
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S3F8S8B Development Kit Documentation
The documents associated with the S3F8S8B Development Kit are listed in Table 1. Each 
of these documents can be obtained from the Zilog website by clicking the link associated 
with its Document Number. Alternatively, navigate to the directory listed in the Location 
column in your installed application.

S3F8S8B Sample Projects
Table 2 lists the sample projects developed for this application. Follow the filepath stated 
in the Location column to access the associated project.

Table 1. S3F8S8B Development Kit Documentation

Document Description Location
UM0273 S3F8S8B Development Kit User Manual Documentation\Tools_Documentation
PS0326 S3F8S8B Product Specification Documentation\Chip_Documentation
UM0266 S3 Flash In-System Programmer User Manual Documentation\Tools_Documentation
FL0171 S3F8S8B0100ZCOG Development Kit Insert Documentation\Tools_Documentation
FL0165 S3 Flash In-System Programmer Insert Documentation\Tools_Documentation
Online Help ZDS II-S3 IDE, Assembler and C Compiler On-Line 

Help
ZDS II-S3 >Help >Help Topics

Table 2. S3F8S8B Sample Projects

Project Location
SB8_Demo samples\S3F8S8B\ISP_BL_Demo
lcd samples\S3F8S8B\S8B_LCD_asm
lcd samples\S3F8S8B\S8B_LCD_C
ledblink samples\S3F8S8B\ledblink_asm
ledblink samples\S3F8S8B\ledblink_c
eeprom samples\S3F8S8B\EEPROM_c
UM027302-0816 S3F8S8B Development Kit Documentation
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ndix A. Schematic Diagrams
Figures 22 and 23 present schematic diagrams of the S3F8S8B Development Board.

Figure 22. S3F8S8B Development Board Schematic Diagram, #1 of 2
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Figure 23. S3F8S8B Development Board Schematic Diagram, #2 of 2
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Customer Support
To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at http:/
support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base or consider par-
ticipating in the Zilog Forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com/
UM027302-0816 Customer Support

http://www.zilog.com/
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_forum&Itemid=67
http://www.zilog.com/index.php?option=com_tech&task=kb&Itemid=84
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