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DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY
ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN LIFE 
SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS PRIOR WRITTEN APPROVAL OF 
THE PRESIDENT AND GENERAL COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for 
use provided in the labeling can be reasonably expected to result in a significant injury to the user. A criti-
cal component is any component in a life support device or system whose failure to perform can be reason-
ably expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2016 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, 
or technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES 
NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED 
IN ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been verified according 
to the general principles of electrical and mechanical engineering. 

S3 and Z8 are trademarks or registered trademarks of Zilog, Inc. All other product or service names are the 
property of their respective owners.

Warning:
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Overview
Zilog’s S3F8S19 Development Kit, part number S3F8S190100ZCOG, allows you to eval-
uate your S3F8S19-based designs and applications. The Kit features a Development 
Board consisting of the following components: 

• Four LEDs 

• Five pushbuttons 

• Buzzer/speaker 

• LCD module 

• UART 

This user manual provides instructions for setting up and configuring the S3F8S19 Devel-
opment Board. It includes schematic diagrams and a discussion of the Board features and 
ZDS II.

The S3F8S19 Development Board features an S3F8S19 MCU in a 48-pin QFP package, 
plus an S3 PGM connector to connect the Board to a host development PC using the S3 
Flash In-System Programmer II (ISP). To learn more about the S3F8S19 MCU, refer to 
the S3F8S19 Product Specification (PS0312) and/or the S3 Flash In-System Programmer 
User Manual (UM0266). 

This document guides you through the following tasks:

• Downloading and installing ZDS II software and documentation 

• Connecting the S3 Flash ISP II and S3F8S19 Development Board to your PC

• Starting the S3F8S19 Ledblink sample program 

Kit Contents
The S3F8S19 Development Kit contains the following items:

• S3F8S19 Development Board

• S3 Flash ISP II

• 10-circuit ribbon cable

• USB A (male) to Mini-B USB cable (2)

• S3F8S19 Development Kit hardcopy insert
UM026803-0816 Overview
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Figure 1 shows the contents of the S3F8S19 Development Kit.

Features
The S3F8S19 Development Kit includes the following key items.

• S3F8S19 Development Board, which contains the following features:
– S3F8S19 48-pin QFP MCU operating at 12 MHz, with 32 KB of internal Flash 

memory and 2 KB of internal RAM memory 
– USB interface to supply power to the board and used as a PC virtual COM port 

with the S3 Monitor and Boot Loader libraries
– LCD module
– Buzzer/Speaker
– UART Connector footprint
– Test Points footprint for all pins of MCU
– MCU current measurement Test Points J7 and J8
– Power Supply level adjustable with potentiometer R16 

• S3 Flash In-System Programmer II

• ZDS II software, samples, and documentation available free for download
– Sample programs

Figure 1. The S3F8S19 Development Kit
UM026803-0816 Features
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Supported Host Environments
The S3F8S19 Development Board supports the following operating systems:

• Microsoft Windows 7 (32-bit/64-bit) 

• Microsoft Windows 8 (32-bit/64-bit)

Install the ZDS II Software and Documentation
Observe the following steps to download and install your ZDS II software and documenta-
tion.

If you have already installed ZDS II – S3 <version> and have downloaded the software 
and documentation by following the procedure on the paper insert in your kit (FL0167), 
skip ahead to the next section.

1. Prior to connecting the S3F8S19 Development Board to your development PC, down-
load ZDS II for S3 Family devices version 5.3.0 (or later) from the Downloadable 
Software category in the Zilog Store.

2. When the download is complete, unzip the file to your hard drive. Double-click the 
installation file named ZDS II – S3_<version>.exe, and follow the on-screen instruc-
tions.

Establish a Connection with the PC
Observe the following procedure to connect the S3 Flash ISP II and S3F8S19 Develop-
ment Board to your PC.

Disconnect or turn off the power to the S3F8S19 Development Board before connecting 
or disconnecting the S3 Flash ISP II.

1. Connect the Mini-B side of the USB A (male)-to-Mini-B cable to the S3 Flash ISP II. 
Connect the other end of this cable to the PC, as shown in Figure 2.

Note:

Caution:
UM026803-0816 Supported Host Environments
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2. Connect the 10p 5x2 ribbon cable to the S3 Flash ISP II, as shown in Figure 3.

3. Connect the other end of the ribbon cable to Jumper J6 on the Development Board. 
Ensure that Pin 1 on the ribbon cable is aligned with Pin 1 on the target connector, as 
indicated in Figure 4.

Figure 2. Connecting the S3 Flash ISP II to the Development PC

Figure 3. Connecting the 10-pin Ribbon Cable to the S3 Flash ISP II
UM026803-0816 Establish a Connection with the PC
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Ensure that you connect the 10 pin ribbon cable using the correct orientation to prevent 
damage to the S3 Flash ISP II.

4. With the USB A (male) to Mini-B cable, connect Port P1 on the S3F8S19 Develop-
ment Board to a USB port on the Development PC to apply power to the Development 
Board, as indicated in Figure 5.

After completing the procedure to connect the S3F8S19 Development Board to the PC, 
the complete setup appears as shown in Figure 6.

Figure 4. Debug Connector J6

Figure 5. Power Supply Port P1 Connector

Caution:
UM026803-0816 Establish a Connection with the PC
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Start the S3F8S19 Ledblink Sample Program
The S3F8S19 Development Kit includes a sample program that demonstrates an LED 
blinking application. To start the S3F8S19 Ledblink sample program, observe the follow-
ing procedure.

1. Launch ZDS II by navigating from the Windows Start menu to Programs → Zilog 
ZDS II – S3 <Version> → ZDS II – S3 <Version>.

2. From the File menu in ZDS II, select Open Project as indicated in Figure 7, and navi-
gate to the following filepath:

<ZDS Install>\samples\S3F8S19\ledblink_asm

Figure 6. The Completed ISP II and Development Board Assembly
UM026803-0816 Start the S3F8S19 Ledblink Sample Program
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3. Select the ledblink.zdsproj project from within the ledblink_asm folder as 
indicated in Figure 8 and click Open. A list of source files will appear in the Work-
space panel.

Figure 7. The Open Project Selection in the File Menu

Figure 8. Select the ledblink.zdsproj Project
UM026803-0816 Start the S3F8S19 Ledblink Sample Program
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4. From the Build menu, select Set Active Configuration to open the Select Configura-
tion dialog box.

5. Select Debug, then click OK to close the Select Configuration dialog box.

6. From the Project menu in ZDS II, select Settings to open the Project Settings dialog 
box. In the Project Settings dialog box, click the Debugger tab.

7. On the Debugger page, select S3F8S1X_FlashIspII from the Target list, then select 
S3FlashIspII from the Debug Tool drop-down menu, as indicated in Figure 9.

Figure 9. Select the Target and Debug Tool
UM026803-0816 Start the S3F8S19 Ledblink Sample Program
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8. After selecting S3FlashIspII from the Debug Tool drop-down menu, click Setup to 
select the serial number of the S3 Flash ISP II you are using, as indicated in Figure 10.

The serial number you see on your screen will be different from the serial number shown 
in Figure 10.

9. Click OK to close the Setup USB Communication dialog box.

10. Make sure that the Enhanced ISP Debug Library is selected.

11. Click OK to close the Project Settings dialog box.

12. If you are prompted to rebuild any affected files, click Yes. Otherwise, choose Build
from the menu bar, then click Rebuild All. The following message is displayed.

OUTPUT CHECKSUM
===============
ledblink.hex         9AC2
ledblink.lod         9AC2

0 warning(s)
0 error(s)
Build succeeded

This Output Checksum message is an example and may not match the actual checksum of 
the project for a particular release of the ZDS installation software.

Figure 10. The Setup USB Communication Dialog

Note:

Note:
UM026803-0816 Start the S3F8S19 Ledblink Sample Program
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13. To run the application, select Reset+Go from the Debug menu, as indicated in 
Figure 11. As a result, LEDs D2, D3, and D4 will blink in sequence.

Trouble Shooting Tips
The following trouble-shooting tips are useful when starting the S3F8S19 Ledblink sam-
ple program.

• Ensure that the LED indicator on the S3 Flash ISP II lights up upon connecting to the 
USB port of your PC.

• Navigate to Project → Settings → Debugger → Debug Tool → Setup. Upon click-
ing Setup on the Setup USB Communication dialog box, verify that S3FlashIspII is 
displayed.

• Remove and reconnect the ISP II on the USB port of your PC.

• Refer to Table 1 on page 12 to learn more about the operations and power options of 
the S3F8S19 Development Board.

Figure 11. Select Reset+ Go from the Debug Menu
UM026803-0816 Trouble Shooting Tips
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S3F8S19 Development Board
The purpose of the S3F8S19 Development Kit is to provide a set of hardware and software 
tools for the development of hardware and firmware for applications based on the 
S3F8S19 microcontroller. An image of the S3F8S19 Development Board is shown in 
Figure 12; a block diagram is shown in Figure 13.

Figure 12. The S3F8S19 Development Board

Figure 13. S3F8S19 Development Board Block Diagram
UM026803-0816 S3F8S19 Development Board
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Operations and Power Options
The operations and power options of the S3F8S19 Development Board are listed in 
Table 1.

S3F8S19 MCU
Key features of the S3F8S19 MCU include: 

• SAM88RC CPU core 

• 32K x 8 bits program memory

• 2,086 × 8 bits data memory 

• Endurance: 10,000 Erase/Program cycles

• 78 instructions

• 40 normal I/O pins in the 48-pin QFP package

• 8 interrupt levels and 26 interrupt sources

• One programmable 8-bit basic timer (BT) for oscillation stabilization control or watch-
dog timer function

• One 16-bit timer/counter (Timer 0) with Interval mode and PWM mode

Table 1. Operations and Power Options of the S3F8S19 Development Board

Option Operations Jumper Status Power Notes
1 Programming

/Debugging
J18 1-2 ON VDD = 3.00 V

VCC_T = 2.95 V
USB cable not connected on P1

J21 1-2 OFF J21 should be OFF when 
programming

2 Programming
/Debugging

J18 1-2 OFF VDD = 3.12 V
VCC_T = 3.30 V

USB cable connected on P1

J21 1-2 OFF J21 should be OFF when 
programming

3 Programming
/Debugging

J18 1-2 ON VDD = 3.30 V
VCC_T = 3.30 V

USB cable connected on P1

J21 1-2 OFF J21 should be OFF when 
programming

4 Stand-Alone J18 1-2 ON VDD = VCC_T = 
3.30 V

USB cable connected on P1

J21 1-2 Not relevant
UM026803-0816 Operations and Power Options



S3F8S19 Development Kit
User Manual

13
• 10-channel analog input

• 10-bit conversion resolution 

• Two-channel Universal Asynchronous Receiver/Transmitter (UART)

• Serial peripheral interface 

• Serial, 8-bit data transfer 

• Programmable clock prescaler

• LCD Controller/Driver 

• Low-voltage check to reset system 

• ISP-related option selectable (ROM address 3EH) via Smart Option

• Oscillator selection, LVR selection (ROM address 3FH) via Smart Option 

To learn more about the S3F8S19 MCU, refer to the S3F8S19/S3F8S15 Product Specifi-
cation (PS0312).

Magnetic Buzzer
The CEM1206S magnetic buzzer (U2) manufactured by CUI Inc. is rated at a frequency 
of 2400 Hz and an operating voltage of 3.0–8.0 V zero-to-peak (V0–P). An image of the 
CEM1206S device is shown in Figure 14.

This buzzer is activated by setting the jumper J9 to the 1-2 position that connects the 
buzzer to the P3.0 pin of the S3F8S19 MCU in the Development Kit.

To learn more about the CEM1206S device, visit http://www.cui.com/product/resource/
cem-1206s.pdf.

Figure 14. Magnetic Buzzer
UM026803-0816 Magnetic Buzzer
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Reset Circuit
The reset circuit features a 100 KΩ pull-up resistor R6 and SW1. This circuit resets the 
S3F8S19 MCU when SW1 is pressed. See Figure 15 for a representation of the reset cir-
cuit.

ISP II Connector
The ISP II connector (J6) provides an interface between the S3 Flash ISP II tool and the 
S3F8S19 device. See Figure 16 for an illustration of the ISP II connector.

Figure 15. The Reset Circuit

Figure 16. The ISP II Connector
UM026803-0816 Reset Circuit
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LCD
The VIM-404-DP-RC-S-HV LCD manufactured by Varitronix Ltd. is a 20-pin module 
seated on both J4 and J5. Figure 17 shows an image of this LCD.

This four-digit LCD is activated by selecting the segment of each digit that must light up. 
Figure 18 shows the LCD pin configuration and assignments.

Figure 17. LCD

Figure 18. LCD Pin Configuration and Assignments
UM026803-0816 LCD
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ZDS Flash Loader Utility
A Flash Loader utility is included in Zilog Developer Studio II via the Tools menu. 
Figure 19 shows an image of the Flash Programming screen.

You can program the S3F8S19 MCU directly using the hex code generated from the ZDS 
IDE tools.

Figure 19. The Flash Loader Programming Screen
UM026803-0816 ZDS Flash Loader Utility
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S3F8S19 Development Kit Documentation
The documents associated with the S3F8S19 Development Kit are listed in Table 2. Each 
of these documents can be obtained from the Zilog website by clicking the link associated 
with its Document Number. Alternatively, navigate to the directory listed in the Location 
column in your installed application.

S3F8S19 Sample Projects
Table 3 lists the sample projects developed for this application. Follow the filepath stated 
in the Location column to access the associated project.

Table 2. S3F8S19 Development Kit Documentation

Document Description Location
UM0268 S3F8S19 Development Kit User Manual Documentation\Tools_Documentation
PS0312 S3F8S19 Product Specification Documentation\Chip_Documentation
UM0266 S3 Flash In-System Programmer User Manual Documentation\Tools_Documentation
FL0167 S3F8S190100ZCOG Development Kit Insert Documentation\Tools_Documentation
FL0165 S3 Flash In-System Programmer Insert Documentation\Tools_Documentation
Online Help ZDS II-S3 IDE, Assembler and C Compiler On-Line 

Help
ZDS II-S3 >Help >Help Topics

Table 3. S3F8S19 Sample Projects

Project Location
S3F8S19_BL_Demo samples\BL_Demo
buzzer samples\buzzer_asm
buzzer samples\buzzer_c
lcd samples\lcd_asm
lcd samples\lcd_c
ledblink samples\ledblink_asm
ledblink samples\ledblink_c
S3F8S19_ISP_Demo samples\ ISP_Demo
UM026803-0816 S3F8S19 Development Kit Documentation
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ndix A. Schematic Diagrams
Figures 20 and 21 present schematic diagrams of the S3F8S19 Development Board.

Figure 20. S3F8S19 Development Board Schematic Diagram, #1 of 2
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Figure 21. S3F8S19 Development Board Schematic Diagram, #2 of 2
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Customer Support
To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at http:/
support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base or consider par-
ticipating in the Zilog Forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com/
UM026803-0816 Customer Support

http://www.zilog.com/
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_forum&Itemid=67
http://www.zilog.com/index.php?option=com_tech&task=kb&Itemid=84
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