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DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY
ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN LIFE 
SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS PRIOR WRITTEN APPROVAL OF 
THE PRESIDENT AND GENERAL COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for 
use provided in the labeling can be reasonably expected to result in a significant injury to the user. A criti-
cal component is any component in a life support device or system whose failure to perform can be reason-
ably expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2016 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, 
or technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES 
NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED 
IN ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been verified according 
to the general principles of electrical and mechanical engineering. 

S3 and Z8 are trademarks or registered trademarks of Zilog, Inc. All other product or service names are the 
property of their respective owners.

Warning:
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Overview
Zilog’s S3F80QB Development Kit, part number S3F80QB0100ZCOG, allows you to 
evaluate your S3F80QB-based designs and applications. The Kit features a Development 
Board consisting of the following components:

• Four LEDs

• Seventeen pushbuttons

• Buzzer/speaker

• Four high-power infrared (IR) emitting diodes

• IR receiver module

• Device pin headers 

This user manual provides instructions for setting up and configuring the S3F80QB
Development Board. It includes schematic diagrams and a discussion of the Board fea-
tures and ZDS II.

The S3F80QB Development Board features an S3F80QB MCU in a 44-pin QFP package, 
plus an S3 PGM connector to connect the Board to a host development PC using the S3 
Flash In-System Programmer II (ISP). To learn more about the S3F80QB MCU, refer to 
the S3F80QB Product Specification (PS0308) and/or the S3 Flash In-System Programmer.

This document guides you through the following tasks:

• Downloading and installing ZDS II software and documentation 

• Connecting the S3 Flash ISP II and S3F80QB Development Board to your PC

• Starting the S3F80QB Ledblink sample program 
UM026704-0816 Overview
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Figure 1 shows the contents of the S3F80QB Development Kit.

Kit Contents
The S3F80QB Development Kit contains the following items:

• S3F80QB Development Board

• S3 Flash ISP II

• 10-circuit ribbon cable

• USB A (male) to Mini-B USB cable (2)

• S3F80QB Development Kit hardcopy insert

Figure 1. The S3F80QB Development Kit
UM026704-0816 Kit Contents
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Features
The S3F80QB Development Kit includes the following key items.

• S3F80QB Development Board, which contains the following features:
– S3F80QB 44-pin QFP MCU operating at 8 MHz, with 63 KB of internal Flash 

memory and 1 KB of internal RAM memory
– USB interface that provides power to the Board
– High-power infrared emitting diode
– Buzzer/Speaker
– IR receiver module
– Test points for all pins of the MCU
– MCU current measurement test points J7 and J8
– Power supply level adjustable with potentiometer R18 

• S3 Flash In-System Programmer II

• ZDS II software, samples, and documentation available free for download
– Sample programs

Supported Host Environments
The S3F80QB Development Board supports the following operating systems:

• Microsoft Windows 7 (32-bit/64-bit) 

• Microsoft Windows 8 (32-bit/64-bit)

Install the ZDS II Software and Documentation
Observe the following steps to download and install your ZDS II software and documenta-
tion.

If you have already installed ZDS II S3 <version> and have downloaded the software and 
documentation by following the procedure on the paper insert in your kit (FL0166), skip 
ahead to the next section.

Note:
UM026704-0816 Features
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1. Prior to connecting the S3F80QB Development Board to your development PC, 
download ZDS II for S3 Family devices version 5.3.0 (or later) from the Download-
able Software category in the Zilog Store.

2. When the download is complete, unzip the file to your hard drive. Double-click the 
installation file named ZDS II – S3_<version>.exe, and follow the on-screen instruc-
tions.

Establish a Connection with the PC
Observe the following procedure to connect the S3 Flash ISP II and S3F80QB Develop-
ment Board to your PC.

Disconnect or turn off the power to the S3F80QB Development Board before connecting 
or disconnecting the S3 Flash ISP II.

1. Connect the Mini-B side of the USB A (male)-to-Mini-B cable to the S3 Flash ISP II. 
Connect the other end of this cable to the PC, as shown in Figure 2.

2. Connect the 10p 5x2 ribbon cable to the S3 Flash ISP II, as shown in Figure 3.

Figure 2. Connect the S3 Flash ISP II to the Development PC

Caution:
UM026704-0816 Establish a Connection with the PC
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3. Connect the other end of the ribbon cable to Jumper J6 on the Development Board. 
Ensure that Pin 1 on the ribbon cable is aligned with Pin 1 on the target connector, as 
indicated in Figure 4.

Figure 3. Connect the 10-Pin Ribbon Cable to the S3 Flash ISP II

Figure 4. Debug Connector J6
UM026704-0816 Establish a Connection with the PC
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When connecting the 10-pin ribbon cable, be sure to use the correct orientation to prevent 
damage to the S3 Flash ISP II.

4. With the USB A (male) to Mini-B cable, connect Port P1 on the S3F80QB Develop-
ment Board to a USB port on the development PC to apply power to the Development 
Board, as indicated in Figure 5.

After completing the procedure to connect the S3F80QB Development Board to the PC, 
the complete setup appears as shown in Figure 6.

Figure 5. The Power Supply Port P1 Connector

Caution:
UM026704-0816 Establish a Connection with the PC
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Start the Ledblink Sample Program
The S3F80QB Development Kit includes a sample program that demonstrates an LED 
blinking application. To get started with the S3F80QB Ledblink sample program, observe 
the following procedure.

1. Launch ZDS II by navigating from the Windows Start menu to Programs → Zilog 
ZDS II – S3 <Version> → ZDS II – S3 <Version>.

2. From the File menu in ZDS II, select Open Project as indicated in Figure 7, and navi-
gate to the following filepath:

<ZDS Install>\samples\S3F80QB\ledblink_asm

Figure 6. The Completed ISP II and Development Board Assembly
UM026704-0816 Start the Ledblink Sample Program
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3. Select the ledblink.zdsproj project from within the ledblink_asm folder as 
indicated in Figure 8 and click Open. A list of source files will appear in the Work-
space panel.

Figure 7. The Open Project Selection in the File Menu
UM026704-0816 Start the Ledblink Sample Program
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4. From the Build menu, select Set Active Configuration to open the Select Configura-
tion dialog box.

5. Select Debug, then click OK to close the Select Configuration dialog box.

6. From the Project menu in ZDS II, select Settings to open the Project Settings dialog 
box. In the Project Settings dialog box, click the Debugger tab.

Figure 8. Select the ledblink.zdsproj Project
UM026704-0816 Start the Ledblink Sample Program
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7. On the Debugger page, select S3F80QX_FlashIspII from the Target list, then select 
S3FlashIspII from the Debug Tool drop-down menu, as indicated in Figure 9.

Figure 9. Select the Target and the Debug Tool
UM026704-0816 Start the Ledblink Sample Program
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8. After selecting S3FlashIspII from the Debug Tool drop-down menu, click Setup to 
select the serial number of the S3 Flash ISP II you are using, as indicated in Figure 10. 

The serial number you see on your screen will be different from the serial number shown 
in Figure 10.

9. Click OK to close the Setup USB Communication dialog box.

10. Make sure tat the Enhanced ISP Debug Library is selected..

11. Click OK to close the Project Settings dialog box.

12. If you are prompted to rebuild any affected files, click Yes. Otherwise, choose Build
from the menu bar, then click Rebuild All. The following example message is dis-
played. 

OUTPUT CHECKSUM
===============
ledblink.hex         E909
ledblink.lod         E909

0 warning(s)
0 error(s)
Build succeeded.

Figure 10. The Setup USB Communication Dialog

Note:
UM026704-0816 Start the Ledblink Sample Program
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This Output Checksum message is an example and may not match the actual checksum of 
the project for a particular release of the ZDS installation software.

13. To run the application, select Reset+Go from the Debug menu, as indicated in 
Figure 11. As a result, LEDs D7, D8, and D9 will blink in sequence.

Trouble Shooting Tips
The following trouble-shooting tips are useful when starting the S3F80QB Ledblink sam-
ple program.

• Ensure that the LED indicator on the S3 Flash ISP II lights up upon connecting to the 
USB port of your PC.

Figure 11. Select Reset+ Go from the Debug Menu

Note:
UM026704-0816 Trouble Shooting Tips
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• Navigate to Project → Settings → Debugger → Debug Tool → Setup. Upon click-
ing Setup on the Setup USB Communication dialog box, verify that S3FlashIspII is 
displayed.

• Remove and reconnect the ISP II on the USB port of your PC.

• Refer to Table 1 on page 15 to learn more about the jumper settings for the S3F80QB
Development Board.

S3F80QB Development Board
The purpose of the S3F80QB Development Kit is to provide a set of hardware and soft-
ware tools for the development of hardware and firmware for applications based on the 
S3F80QB microcontroller. An image of the S3F80QB Development Board is shown in 
Figure 12; a block diagram is shown in Figure 13.

U4 is for factory use only and is intentionally not populated.

Figure 12. The S3F80QB Development Board

Note:
UM026704-0816 S3F80QB Development Board
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Power Sources
The Board features two power source options:

• Connecting Port P1 (USB Mini-B) to the USB port of the PC using the USB A-to-USB 
Mini-B cable included in the Kit

• Connecting an external 5 VDC source to J11 (5VDC) and J13 (GND)

S3F80QB MCU
Key features of the S3F80QB MCU include: 

• SAM8 RC CPU core

• 63 KB internal Flash memory, which is user programmable by LDC instruction

• 2  KB or 3.75 KB internal RAM 

• Endurance of 10,000 Erase/Program cycles

• 1  KB RAM executable memory

• 272 byte general purpose RAM data memory

• 78 instructions

Figure 13. S3F80QB Development Board Block Diagram
UM026704-0816 Power Sources
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• IDLE and STOP instructions added for power-down modes

• 125 ns at 8 MHz fOSC (minimum)

• 24 interrupt sources with 18 vectors and 9 levels

• Four 8-bit I/O ports (P0-P2, P4) and 6-bit port (P3) for a total of 38 bit-programmable 
pins (44-pin QFP)

• Three 8-bit n-channel open-drain pins (P1, P2, P4) and one 2-bit n-channel open-drain 
pins (P3 on the 44-pin QFP package)

• One 8-bit counter with auto-reload function and one-shot or repeat control (Counter A)

• One programmable 8-bit basic timer (BT) for oscillation stabilization control or watch-
dog timer (software reset) function

• One 8-bit timer/counter (Timer 0) with three operating modes: Interval, Capture, and 
PWM

• One 16-bit timer/counter (Timer 1) with two operating modes: Interval and Capture

• One 16-bit timer/counter (Timer 2) with two operating modes: Interval and Capture 

To learn more about the S3F80QB MCU, refer to the S3F80QB Product Specification 
(PS0308).

Jumper Settings
Jumper settings for the S3F80QB Development Kit are listed in Table 1.

Magnetic Buzzer
The CEM1206S magnetic buzzer (U2) manufactured by CUI Inc. is rated at a frequency 
of 2400 Hz and an operating voltage of 3.0–8.0 V zero-to-peak (V0–P). An image of the 
CEM1206S device is shown in Figure 14.

Table 1. Jumper Settings

Jumper Name Description State Function Factory Setting
J9 P3.0 1-2 IN Buzzer IN

2-3 IN IR RX In OUT
J10 IR TX IN 1-2 IN LOW IN

2-3 IN HIGH OUT
UM026704-0816 Jumper Settings
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This buzzer is activated by setting the jumper J9 to the 1-2 position that connects the 
buzzer to the P3.0 pin of the S3F80QB MCU in the Development Kit.

To learn more about the CEM1206S device, visit http://www.cui.com/product/resource/
cem-1206s.pdf.

IR Receiver for Remote Control Systems
The TSOP31238 device is a member of the TSOP312–TSOP314 Series IR receivers (D2), 
which are miniaturized IR receivers designed to work with infrared remote control sys-
tems. A PIN diode and a preamplifier are assembled on a lead frame. The epoxy package 
contains an IR filter. The demodulated output signal can be directly connected to a micro-
processor for decoding. See Figure 15 for an image of an IR receiver module.

Figure 14. The CEM1206S Magnetic Buzzer

Figure 15. The TSOP31238 IR Receiver Module
UM026704-0816 IR Receiver for Remote Control Systems
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This IR receiver is connected to the P3.0 pin of the MCU by placing J9 into the 2-3 posi-
tion. To learn more about the TSOP31238 device, visit http://www.vishay.com/docs/
82492/tsop312.pdf.

High-Power Infrared-Emitting Diode
The TSAL6200 diode (D3, D4, D5, D6) is an infrared (940 nm wavelength) emitting diode 
employing GaAlAs/GaAs technology with high radiant power, and molded in a blue-gray 
plastic package. An image of the TSAL6200 device is shown in Figure 16.

Of two pairs of IR LEDs, D3/D4 and D5/D6, the D3/D4 pair is activated by placing 
Jumper J10 into the 2-3 position for an active High transmission. The D5/D6 pair is acti-
vated by placing a shunt onto J10 position 1-2 for an active Low transmission. Either of 
these jumper settings connects its correlated pair to P3.1 on the MCU.

To learn more about the TSAL6200 device, visit http://www.vishay.com/docs/81010/
tsal6200.pdf.

Reset Circuit
The reset circuit features a 100 KΩ pull-up resistor R8 and SW1. This circuit resets the 
S3F80QB MCU when SW1 is pressed. See Figure 17 for a representation of the reset cir-
cuit.

Figure 16. TSAL6200 Infrared Emitting Diodes
UM026704-0816 High-Power Infrared-Emitting Diode
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http://www.vishay.com/docs/81010/tsal6200.pdf
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Keypad Circuit
The keypad circuit features 16 switches connected to eight pins on the MCU. These pins 
are configured as outputs for P1.3–P1.0, and are configured as inputs with pull-ups 
enabled for P0.7–P0.4. The keypad circuit is shown in Figure 18.

ISP II Connector
The ISP II connector (J6) provides an interface between the S3 Flash ISP II tool and the 
S3F80QB device. See Figure 19 for an illustration of the ISP II connector.

Figure 17. The Reset Circuit

Figure 18. The Keypad Circuit
UM026704-0816 Keypad Circuit
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ZDS Flash Loader Utility
A Flash Loader utility is included in Zilog Developer Studio II via the Tools menu. 
Figure 20 shows an image of the Flash Programming screen.

Figure 19. The ISP II Connector
UM026704-0816 ZDS Flash Loader Utility
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Figure 20. The Flash Programming Screen
UM026704-0816 ZDS Flash Loader Utility
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S3F80QB Development Kit Documentation
The documents associated with the S3F80QB Development Kit are listed in Table 2. Each 
of these documents can be obtained from the Zilog website by clicking the link associated 
with its Document Number. Alternatively, navigate to the directory listed in the Location 
column in your installed application.

Table 3 lists the two sample projects developed for this application. Follow the filepath 
listed in the Location column to access the associated project.

Table 2. S3F80QB Development Kit Documentation

Document Description Location
PS0308 S3F80QB Product Specification Documentation\Chip_Documentation
UM0266 S3 Flash In-System Programmer User Manual Documentation\Tools_Documentation
UM0267 This S3F80QBDevelopment Kit User Manual Documentation\Tools_Documentation
Online Help ZDS II – S3 IDE, Assembler and C Compiler 

online help
ZDS II – S3 > Help > Help Topics

FL0165 S3 Flash In-System Programmer insert Documentation\Tools_Documentation
FL0166 S3F80QB Development Kit insert Documentation\Tools_Documentation

Table 3. S3F80QB Sample Projects

Project Location
Ledblink Samples\S3F80QB\ledblink_asm
Ledblink Samples\S3F80QB\ledblink_c
Ledblink Samples\S3F80QB\ISP_BL_Demo
Demo Samples\S3F80QB\Demo_asm
ExeRam Samples\S3F80QB\executableRAM
UM026704-0816 S3F80QB Development Kit Documentation
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ndix A. Schematic Diagrams
Figures 21 and 22 present schematic diagrams of the S3F80QB Development Board.

Figure 21. S3F80QB Development Board Schematic Diagram, #1 of 2
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Figure 22. S3F80QB Development Board Schematic Diagram, #2 of 2
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Customer Support
To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at http:/
support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base or consider par-
ticipating in the Zilog Forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog
UM026704-0816 Customer Support

http://www.zilog.com/
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_product&task=tech_support&Itemid=85
http://www.zilog.com/index.php?option=com_forum&Itemid=67
http://www.zilog.com/index.php?option=com_tech&task=kb&Itemid=84

	Revision History
	S3F80QB Development Kit
	Overview
	Kit Contents
	Features
	Supported Host Environments
	Install the ZDS II Software and Documentation
	Establish a Connection with the PC
	Start the Ledblink Sample Program
	Trouble Shooting Tips

	S3F80QB Development Board
	Power Sources
	S3F80QB MCU
	Jumper Settings
	Magnetic Buzzer
	IR Receiver for Remote Control Systems
	High-Power Infrared-Emitting Diode
	Reset Circuit
	Keypad Circuit
	ISP II Connector
	ZDS Flash Loader Utility
	S3F80QB Development Kit Documentation
	Appendix A. Schematic Diagrams
	Customer Support


