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Abstract
The Zilog Development Studio II (ZDS II) Inte-
grated Development Environment (IDE) can flash 
a specified hex file to memory using either the 
Flash Loader dialog or the command processor’s 
Flash Loader interface. Using the command pro-
cessor provides a simplified interface that reduces 
the number of steps required to program multiple 
Flash Memory targets. 

The ZDS II Flash Loader function was introduced 
with Version 4.5.0 of the ZDS II IDE.

Overview of the ZDS II Command 
Processor
The ZDS II command processor gives you com-
mand-script access to all IDE functions. The com-
mand processor Flash Loader is an extension of 
this capability. Flash Loader commands can be 
typed directly into the command processor or used 
in BATCH scripts. This allows easy automation of 
the Flash loading process. 

Flash Loader parameters are persistent. Repeated 
operations on multiple targets use the most recent 
settings, made either in the Flash Loader dialog or 
by using the Flash Options command in the com-
mand processor.

Configuring ZDS II Virtual Flash 
Devices
The eZ80® and eZ80Acclaim!® development and 
evaluation platforms contain an external Flash 
Memory component. The ZDS II Flash Loader 
provides the ability to define that component as a 
set of virtual Flash devices. The Flash Loader 
dialog refers to these as external Flash devices; 

they are in reality segments of external Flash Mem-
ory defined as virtual Flash devices. The configu-
ration for these virtual Flash devices is defined in 
an XML file named flashdevice.xml, located 
in:

<INSTALL DIRECTORY>\Zilog\ZDS 
_<Processor>_<version>\config

The flashdevice.xml file defines the config-
uration for the eZ80 and eZ80Acclaim! external 
Flash component, and some other available Flash 
devices. The XML file uses the syntax listed in 
Table 1 on page 2.

The eZ80Acclaim! processors
feature internal Flash Memory
and external Flash Memory. In-
ternal Flash device configura-
tion is defined in an XML file
na med  CPUflashde-
vice.xml. Do not attempt to
modify this file.

Caution:
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You can create, delete, and alter virtual Flash 
devices by adding or removing Flash_Device block 
elements in the FlashDevice.xml file, and 
modifying the device name and page address range 
elements. However, the device-specific values and 
sequence elements must be preserved and be 
present for each defined Flash virtual device. An 
example FlashDevice.xml file is described in 

Appendix A—FlashDevice.xml File Listing on 
page 8.

You can select a virtual Flash device in the Flash 
Loader dialog, or by using the MANUF...DEVICE 
option in the Command Processor Flash command, 
which is explained in the following section.

Table 1. FlashDevice.xml File Syntax

Syntax Description

<flash> Begin Flash Device Database

<Manufacture name="company"> Begin Flash Device Manufacturer

<Flash_Device name="name"> Begin Flash Device

<Device_ID>number</Device_ID> Device ID from product specifications

<Manuf_ID>number</Manuf_ID> Manufacturer ID from product specifications

<readDeviceOffset>1 or 2</readDeviceOffset> Read offset for ID: 1 = byte, 2 = word

<deviceSize>hex value</deviceSize> Overall size of Flash device in hexadecimal

<readArray>hex value</readArray> Read array, defined in product specification

<Sequence name="name"> Begin command sequence definition, where 
name is one of the following: 
Identify—Read manufacture and device ID 
Write—Unlock flash and write bytes
Erase—Unlock flash and erase a page

<Data>hex value</Data>
<Data>hex value</Data>
...

Specify each byte in command sequence, 
from product specifications

</Sequence> End command sequence

<eraseVerifyValue>hex value</eraseVerify-
Value>

Define erase verify value

<eraseVerifyMask>hex value</eraseVerifyMask> Define erase verify mask

<page>first last</page>
<page>first last</page>
...

Define Flash device pages or sections, where 
first and last are the first and last address of 
each page, in hexadecimal 

</Flash_Device> End Flash Device

<Manufacture> End Flash Device Manufacturer

</flash> End Flash Device Database
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For example, the following Flash Loader command 
would cause subsequent commands to reference 
the Micron MT28F008B3xx-xxB device defined in 
FlashDevice.xml:

FLASH OPTIONS MANUF="Micron" 
DEVICE="MT28F008B3xx-xxB"

Using the ZDS II Command 
Processor Flash Loader
Flash Loader commands are executed from the 
ZDS II command processor toolbar, as displayed in 
Figure 1. To execute a command, type the com-
mand in the text entry field and then click Go 
button .

Figure 1. ZDS II Command Processor

Follow the steps below to run the command 
processor Flash Loader:

1. Create or open a project with eZ80F91,
eZ80F92, eZ80F93, eZ80L92, or eZ80190

selected in the CPU field on the General tab
of the Project Settings dialog box. 

2. Configure the Chip Select parameters. The 
Flash Loader requires both RAM for execution 
and the correct external Flash Memory chip 
select parameters and memory limits. If there 
is internal RAM, the Flash Loader uses that 
memory for execution. The parameters are 
entered in the Initializations Dialog Box 
(Project → Settings → Debugger → Initial-
ization Params…).

3. In the Configure ZPAK II dialog box, specify 
the ZPAK II Ethernet address. The Flash 
Loader uses the ZPAK II to communicate with 
the target.

4. In the command processor toolbar, type com-
mands in the following format to use the Flash 
Loader. Click Go  to execute each com-
mand.
FLASH command_keyword [parameter] 
[REPEAT]

[ ] indicates optional fields. Com-
mands and keywords can be typed in
either uppercase or lowercase. 

Table 2 lists Flash Loader commands and key-
words.

Note:

Table 2. Flash Command Keywords and Parameters

Command 
Keyword Parameter Description

SETUP Displays the current Flash Loader parameter settings 
in the Command Output window.

HELP Displays the Flash command format in the command 
window.

ERASE Erase Flash.
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BURN Burn Flash using current Flash Loader parameter 
settings.

BURNVERIFY Burn and Verify Flash.

VERIFY Verify Flash.

REPEAT (Optional command suffix.) Repeats execution of the 
ERASE, BURN, BURNVERIFY, or VERIFY com-
mand. The Flash Loader executes the command, dis-
connects from the target, and then prompts to repeat 
the operation. You are given the option to continue or 
stop. If the SI option is set, the serial number is incre-
mented after each burn.

OPTIONS "filename" The file to be flashed. The file name must include the 
absolute path and must be enclosed by double quo-
tation marks, for example:
FLASH OPTIONS "C:\Program File\test.hex"
Note: If you reference files across a network, use the 
File Explorer Tools → Map a Network Drive option to 
map the remote file system as a network drive letter 
and use the network drive letter in your command 
files instead of the full network path.

FLASHBASE = "address" Start location for external Flash (eZ80Acclaim! family 
processors only).

NUMFLASH = number Number of stack flash devices.

OFFSET = "hex value" Offset for the specified memory segment. The speci-
fied file is shifted by the offset amount. If BOTHMEM 
is set, the offset is applied to both the internal and 
external memory segments. Example:     FLASH 
OPTIONS OFFSET = "0x10000".

INTMEM Set target to internal Flash Memory.

EXTMEM Set target to external Flash Memory.

BOTHMEM Set target to internal and external Flash Memory.

MANUF="company" 
DEVICE="name"

Set target device manufacturer and device name, as 
defined in FlashDevice.xml.

NEBF No erase before Flash.

EBF Erase before Flash.

NEIP No erase info page.

EIP Erase info page.

NSI No serial number included.

Table 2. Flash Command Keywords and Parameters (Continued)

Command 
Keyword Parameter Description
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Parameters can be set using either
the Options keyword or the Flash
Loader dialog box. If you do not
specify an Options parameter, the
current setting in the Flash Loader
dialog box is used. Changing an
Options parameter also changes the
corresponding setting in the Flash
Loader dialog box.

Example
The following are examples for a target with an 
eZ80F91 and external Flash Memory. 

Commands and keywords can be
t y pe d  i n  e i t h e r  u pp e rca s e  o r
lowercase.

FLASH OPTIONS INTMEM 
FLASH OPTIONS "c:\testing\test.hex" 
FLASH OPTIONS OFFSET="0x1000" 
FLASH OPTIONS EBF
FLASH BURN REPEAT

The file test.hex is loaded into internal Flash 
Memory with a value of 0x1000 added to all 
addresses. The Flash Memory is erased before 
flashing. After the flashing is completed, you are 
prompted to program an additional unit.

FLASH VERIFY

The file test.hex is verified against internal 
Flash Memory with an offset value of 0x1000.

FLASH OPTIONS MANUF="Micron" 
DEVICE="MT28F008B3xx-xxB"
FLASH VERIFY

The file test.hex (from the first example) is 
verified against the specified external Flash, as 
defined in FlashDevice.xml.

FLASH SETUP

The current Flash Loader parameters settings are 
displayed in the Command Output window.

FLASH HELP

The current Flash Loader command options are 
displayed in the Command Output window.

Flashing with a Command 
Processor Batch File
You can use the BATCH filename.txt com-
mand in the ZDS II command processor interface 
to specify a plain text file containing a sequence of 
commands. The IDE executes the commands in the 
batch file one at a time. The following ZDS II 
batch file erases, burns, and verifies Flash Memory, 
and then repeats for one or more additional targets:

SI Serial number included.

SERIALADDRESS = "address" Start location for serial number.

SERIALNUMBER = "number" Serial number initial value (in hexadecimal).

SERIALSIZE = bytes Number of bytes (1–8) in serial number.

INCREMENT = "value" Increment value (in decimal) for serial number.

NIP No info page.

IP Info page.

Table 2. Flash Command Keywords and Parameters (Continued)

Command 
Keyword Parameter Description

Note:

Note:
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;  <Begin File Flashcmd.txt  >
;******************************************************************
;Change directory to location of Hex file
cd "<INSTALL DIRECTORY>\zilog\<product><version>\myproject\src"

;Open Project file
open project "<INSTALL 
DIRECTORY>\Zilog\<product><version>\myproject\src\boardprog.pro"

;Select Internal memory segment
flash options intmem

;Set Erase Before Flash
flash options ebf

;Set file to be flashed
flash options ".\boardprog.hex"

’Execute flash command
flash burnverify repeat

;Wait 2 seconds
wait 2000

;exit ZDS II
exit
;*******************************************************************
; <End File Flashcmd.txt  >

The batch file example above is based on the 
following:

• A valid project is created that has the correct 
memory map for target Flash and RAM.

• The project is already been built and does not 
need to be rebuilt before flashing.

• The project is built in the release Flash configu-
ration (.hex).

• The first target is connected and has power 
applied.

• The project has the correct Ethernet address 
selected for the ZPAK.

• The project is using internal Flash only and the 
default MANUF...DEVICE option is used.

To run the batch file, enter the following command 
in the ZDS II Command Processor box: 

BATCH "c:\flashcmd.txt"

Flashing with a DOS Batch File
Use a Windows DOS batch (.bat) file to execute a 
ZDS II batch file that flashes a target. The DOS 
batch file contains commands that start ZDS II and 
pass a specified Command Processor batch file. In 
the DOS batch file, the ‘@’ symbol following the 
ZDS2IDE.exe command causes the IDE to pro-
cess the specified command file after starting the 
ZDS II user interface. It is equivalent to starting 
ZDS II and then entering the command BATCH 
‘c:\Flashcmd.txt’ in the command processor 
window.
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In Windows 98, use start /wait to call the ZDS II executable.
Windows 98SE Example
REM The following two lines should be entered as a single line. 
start /wait "<INSTALL DIRECTORY>\Zilog\<product><version>\bin\Zds2Ide.exe" 
@c:\Flashcmd.txt

Windows XP, Windows 2000, and Windows NT Example
REM The following two lines should be entered as a single line. 
"<INSTALL DIRECTORY>\Zilog\<product><version>\bin\Zds2Ide.exe" 
@c:\Flashcmd.txt 

Combined Windows XP, Windows 2000, Windows NT and Windows 98SE Example
set ostype=win98
if %OS%!==Windows_NT! set ostype=NT
if %ostype%==NT goto nt1

:win98
REM The following two lines should be entered as a single line.
start /wait "<INSTALL DIRECTORY>\Zilog\<product><version>\bin\Zds2Ide.exe" 
@c:\Flashcmd.txt
goto exit01

:nt1
REM The following two lines should be entered as a single line.
"<INSTALL DIRECTORY>\Zilog\ <product><version>\bin\Zds2Ide.exe" 
@c:\Flashcmd.txt

:exit01

Flashing with a Desktop Shortcut
You can create a shortcut on the computer desktop 
that points to a DOS batch file in the ZDS II direc-
tory to minimize the number of the steps required 
to flash a target. To create the shortcut, right-click 
the batch file name and select ‘Create Shortcut’. A 
shortcut is created in the same folder as the DOS 
batch file. Drag or copy the shortcut to the desktop.

Summary
The ZDS II Command Processor Flash Loader 
provides a tool for you to flash eZ80 and 
eZ80Acclaim! Flash microprocessors. You can 
automate the flashing process using a combination 
of DOS Batch files and ZDS II command files.

References
The documents associated with eZ80® and 
eZ80Acclaim!® available on www.zilog.com are 
provided below:

• Zilog Developer Studio II—eZ80Acclaim!® 
User Manual (UM0144)

• Zilog Developer Studio II —eZ80® User 
Manual (UM0123)

• For the latest syntax and for additional examples 
that are supported by the ZDS II FLASH com-
mand, refer to the On-Line Help (Help → Help 
Topics → Index → flash → Flash Loader, run-
ning from the command line).

Note:
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Appendix A—FlashDevice.xml File Listing
<flash>
<!--******************************************************************* -->
<!-- Zilog Flash Device XML Database                                    -->
<!-- This file can be modified to add different flash devices or        -->
<!-- multiple instances of a single flash device.                       -->
<!--                                                                    -->
<!-- Zilog Development Tools only validates the Flash Devices that are  -->
<!-- defined with the release of the Zilog Development Tools.           -->
<!--                                                                    -->
<!-- This file can be open using a standard browser.  If the            -->
<!-- browser generates an error the file has an illegal format.         -->
<!--                                                                    -->
<!-- Limitations:                                                       -->
<!-- Comments are limited to a single line                              -->
<!-- Blank lines are not allowed                                        -->
<!--******************************************************************* -->

<version>04032501</version>
<!-- Defines a folder named that will contain a set of flash devices -->
<Manufacture name="Micron">

<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="MT28F008B3xx-xxB">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>99</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>89</Manuf_ID>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>1</readDeviceOffset>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read array defined in product specification -->
<readArray>FF</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Data>90</Data>
</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Data>50</Data>
<Data>40</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Data>50</Data>
<Data>20</Data>
<Data>d0</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>f8</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
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<page>0000 3FFF</page>
<page>4000 5FFF</page>
<page>6000 7FFF</page>
<page>8000 1FFFF</page>
<page>20000 3FFFF</page>
<page>40000 5FFFF</page>
<page>60000 7FFFF</page>
<page>80000 9FFFF</page>
<page>A0000 BFFFF</page>
<page>C0000 DFFFF</page>
<page>E0000 FFFFF</page>

</Flash_Device>
<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="MT28F008B3xx-xxT">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>99</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>89</Manuf_ID>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>1</readDeviceOffset>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read array defined in product specification -->
<readArray>FF</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Data>90</Data>
</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Data>50</Data>
<Data>40</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Data>50</Data>
<Data>20</Data>
<Data>d0</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>f8</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>00000 1FFFF</page>
<page>20000 3FFFF</page>
<page>40000 5FFFF</page>
<page>60000 7FFFF</page>
<page>80000 9FFFF</page>
<page>A0000 BFFFF</page>
<page>C0000 DFFFF</page>
<page>E0000 F7FFF</page>
<page>F8000 F9FFF</page>
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<page>FA000 FBFFF</page>
<page>FC000 FFFFF</page>

</Flash_Device>
</Manufacture>
<!-- Defines a folder named that will contain a set of flash devices -->
<Manufacture name="AMD">

<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="Am29LV160BB">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>49</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>01</Manuf_ID>
<!-- Read offset for the identifier 1-Byte 2-Word-->
<readDeviceOffset>2</readDeviceOffset>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>1FFFFF</deviceSize>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>80</Data>
<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
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<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>0000 3FFF</page>
<page>4000 5FFF</page>
<page>6000 7FFF</page>
<page>8000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 FFFFF</page>
<page>100000 103FFF</page>
<page>104000 105FFF</page>
<page>106000 107FFF</page>
<page>108000 10FFFF</page>
<page>110000 11FFFF</page>
<page>120000 12FFFF</page>
<page>130000 13FFFF</page>
<page>140000 14FFFF</page>
<page>150000 15FFFF</page>
<page>160000 16FFFF</page>
<page>170000 17FFFF</page>
<page>180000 18FFFF</page>
<page>190000 19FFFF</page>
<page>1A0000 1AFFFF</page>
<page>1B0000 1BFFFF</page>
<page>1C0000 1CFFFF</page>
<page>1D0000 1DFFFF</page>
<page>1E0000 1EFFFF</page>
<page>1F0000 1FFFFF</page>

</Flash_Device>
<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="Am29LV160BT">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>C4</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>01</Manuf_ID>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>2</readDeviceOffset>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>1FFFFF</deviceSize>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
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<Sequence name="Identify">
<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>80</Data>
<Address>AAA</Address>
<Data>AA</Data>
<Address>555</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>0000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 FFFFF</page>
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<page>108000 10FFFF</page>
<page>110000 11FFFF</page>
<page>120000 12FFFF</page>
<page>130000 13FFFF</page>
<page>140000 14FFFF</page>
<page>150000 15FFFF</page>
<page>160000 16FFFF</page>
<page>170000 17FFFF</page>
<page>180000 18FFFF</page>
<page>190000 19FFFF</page>
<page>1A0000 1AFFFF</page>
<page>1B0000 1BFFFF</page>
<page>1C0000 1CFFFF</page>
<page>1D0000 1DFFFF</page>
<page>1E0000 1EFFFF</page>
<page>1F0000 1F7FFF</page>
<page>1F8000 1F9FFF</page>
<page>1FA000 1FBFFF</page>
<page>1FC000 1FFFFF</page>

</Flash_Device>
</Manufacture>
<!-- Defines a folder named that will contain a set of flash devices -->
<Manufacture name="STMicro">

<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="M29W008AB">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>DC</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>20</Manuf_ID>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>1</readDeviceOffset>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
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<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>80</Data>
<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>0000 3FFF</page>
<page>4000 5FFF</page>
<page>6000 7FFF</page>
<page>8000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 FFFFF</page>

</Flash_Device>
<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="M29W008AT">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>D2</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>20</Manuf_ID>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>1</readDeviceOffset>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Address>555</Address>
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<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>555</Address>
<Data>80</Data>
<Address>555</Address>
<Data>AA</Data>
<Address>2AA</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>0000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 F7FFF</page>
<page>F8000 F9FFF</page>
<page>FA000 FBFFF</page>
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<page>FC000 FFFFF</page>
</Flash_Device>

        </Manufacture>
<Manufacture name="Atmel">

<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="AT49BV162A">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>C0</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>1F</Manuf_ID>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>2</readDeviceOffset>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>80</Data>
<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
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<!-- Defines the Flash Device pages or sections-->
<page>0000 1FFF</page>
<page>2000 3FFF</page>
<page>4000 5FFF</page>
<page>6000 7FFF</page>
<page>8000 9FFF</page>
<page>A000 BFFF</page>
<page>C000 DFFF</page>
<page>E000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 FFFFF</page>
<page>110000 11FFFF</page>
<page>120000 12FFFF</page>
<page>130000 13FFFF</page>
<page>140000 14FFFF</page>
<page>150000 15FFFF</page>
<page>160000 16FFFF</page>
<page>170000 17FFFF</page>
<page>180000 18FFFF</page>
<page>190000 19FFFF</page>
<page>1A0000 1AFFFF</page>
<page>1B0000 1BFFFF</page>
<page>1C0000 1CFFFF</page>
<page>1D0000 1DFFFF</page>
<page>1E0000 1EFFFF</page>
<page>1F0000 1FFFFF</page>

</Flash_Device>
<!-- Defines the Device name or part number used uniquely identify the device-->
<Flash_Device name="AT49BV162AT">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>C2</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>1F</Manuf_ID>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>2</readDeviceOffset>
<!-- Read array defined in product specification -->
<readArray>F0</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Address>AAA</Address>
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<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>90</Data>

</Sequence>
<!-- Defines the write sequence to unlock flash and write bytes-->
<Sequence name="Write">

<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>A0</Data>

</Sequence>
<!-- Defines the write verify value and mask-->
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<!-- Defines the erase sequence to unlock flash and erase a page of flash-->
<Sequence name="Erase">

<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>AAA</Address>
<Data>80</Data>
<Address>AAA</Address>
<Data>AA</Data>
<Address>554</Address>
<Data>55</Data>
<Address>XXX</Address>
<Data>30</Data>

</Sequence>
<!-- Defines the erase verify value and mask-->
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>80</eraseVerifyMask>
<!-- Defines the Flash Device pages or sections-->
<page>0000 FFFF</page>
<page>10000 1FFFF</page>
<page>20000 2FFFF</page>
<page>30000 3FFFF</page>
<page>40000 4FFFF</page>
<page>50000 5FFFF</page>
<page>60000 6FFFF</page>
<page>70000 7FFFF</page>
<page>80000 8FFFF</page>
<page>90000 9FFFF</page>
<page>A0000 AFFFF</page>
<page>B0000 BFFFF</page>
<page>C0000 CFFFF</page>
<page>D0000 DFFFF</page>
<page>E0000 EFFFF</page>
<page>F0000 FFFFF</page>
<page>100000 10FFFF</page>
<page>110000 11FFFF</page>
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<page>120000 12FFFF</page>
<page>130000 13FFFF</page>
<page>140000 14FFFF</page>
<page>150000 15FFFF</page>
<page>160000 16FFFF</page>
<page>170000 17FFFF</page>
<page>180000 18FFFF</page>
<page>190000 19FFFF</page>
<page>1A0000 1AFFFF</page>
<page>1B0000 1BFFFF</page>
<page>1C0000 1CFFFF</page>
<page>1D0000 1DFFFF</page>
<page>1E0000 1EFFFF</page>
<page>1F0000 1F1FFF</page>
<page>1F2000 1F3FFF</page>
<page>1F4000 1F5FFF</page>
<page>1F6000 1F7FFF</page>
<page>1F8000 1F9FFF</page>
<page>1FA000 1FBFFF</page>
<page>1FC000 1FDFFF</page>
<page>1FE000 1FFFFF</page>

</Flash_Device>
        </Manufacture>
    <!-- Custom Flash Configuration to support L92 and F92 Jump configuration -->

<Manufacture name="Custom">
<Flash_Device name="MT28F008B3 w/Jmp Vectors">

<!-- Flash Device identifier defined in the product specifications-->
<Device_ID>99</Device_ID>
<!-- Manufacture identifier defined in the product specifications-->
<Manuf_ID>89</Manuf_ID>
<!-- Read offset for the identifier 1-Byte 2-Word -->
<readDeviceOffset>1</readDeviceOffset>
<!-- Define the overall Size of the Flash Device -->
<deviceSize>FFFFF</deviceSize>
<!-- Read array defined in product specification -->
<readArray>FF</readArray>
<!-- Defines the Identify sequence to read the manufacture and device ID -->
<Sequence name="Identify">

<Data>90</Data>
</Sequence>
<readArray>ff</readArray>
<Sequence name="Write">

<Data>50</Data>
<Data>40</Data>

</Sequence>
<UnlockVerifyValue>80</UnlockVerifyValue>
<UnlockVerifyMask>f8</UnlockVerifyMask>
<Sequence name="Erase">

<Data>50</Data>
<Data>20</Data>
<Data>d0</Data>

</Sequence>
<eraseVerifyValue>80</eraseVerifyValue>
<eraseVerifyMask>f8</eraseVerifyMask>
<page>0000 3fff</page>
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<page>4000 5fff</page>
<page>6000 7fff</page>
<page>8000 1ffff</page>
<page>20000 3ffff</page>
<page>40000 5ffff</page>
<page>60000 7ffff</page>
<page>80000 9ffff</page>
<page>a0000 bffff</page>
<page>c0000 dffff</page>
<page>e0000 fffff</page>

                        <!-- Insert Jump Vectors at the specified locations -->
                        <!-- Support L92 and F92 processors                 -->
                           <interruptJumpTableBase>8000</interruptJumpTableBase>
                           <interruptJumpDestination>C00000</interruptJumpDestination> 

</Flash_Device>
</Manufacture>

</flash>
AN016704-0908  Page 20 of 21



AN016704-0908  Page 21 of 21
21

Using the ZDS Command Processor for eZ80® and eZ80Acclaim!® Flash Loading
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LIFE SUPPORT POLICY
ZILOG'S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN LIFE
SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS PRIOR WRITTEN APPROVAL OF
THE PRESIDENT AND GENERAL COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b)
support or sustain life and whose failure to perform when properly used in accordance with instructions for
use provided in the labeling can be reasonably expected to result in a significant injury to the user. A
critical component is any component in a life support device or system whose failure to perform can be
reasonably expected to cause the failure of the life support device or system or to affect its safety or
effectiveness.

Document Disclaimer
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property of their respective owners. 

Warning:


	Using the ZDS Command Processor for eZ80® and eZ80Acclaim!® Flash Loading
	Abstract
	Overview of the ZDS II Command Processor
	Configuring ZDS II Virtual Flash Devices

	Using the ZDS II Command Processor Flash Loader
	Example
	Flashing with a Command Processor Batch File
	Flashing with a DOS Batch File
	Flashing with a Desktop Shortcut

	Summary
	References
	Appendix A-FlashDevice.xml File Listing


<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


