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Using the eZ80Acclaim!™ Smart Flash 
Programmer

The eZ80Acclaim!™ Smart Flash Programmer is a software tool used to 
automate programming of Flash memory in targets using eZ80Acclaim! 
microcontrollers. 

In a production environment, a manufacturing engineer uses the Smart 
Flash Programmer’s Advanced Configuration interface to create Flash 
project files. Project files store the configuration settings needed to burn 
Flash memory on a specific target.

Once a project is configured, factory technicians use the Smart Flash Pro-
grammer’s simplified interface to automate Flash memory programming 
on an assembly line.

This user manual provides instructions that support:

• Configuration of the Smart Flash Programmer by a manufacturing 
engineer or technician. See "Configuration" on page 4 for details.

• Operation of the Smart Flash Programmer by a factory worker. See 
"Programming Flash Memory" on page 28 for operation instructions.

The following reference sections are also provided:

• "Starting the Smart Flash Programmer from a Command Line" on 
page 31.

• "Project Workspace Window" on page 32.

• "Status Window" on page 38.
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Tool Requirements
Use of the eZ80Acclaim! Smart Flash Programmer requires a ZPAK II 
cable (found in any eZ80Acclaim! development kit), a CAT5 Ethernet 
cable, or a ZiLOG® USB Smart Cable (purchased separately, not avail-
able for Windows NT), or the serial smart cable suppled with the 
eZ80F91 contest kit. The cable is used to connect your manufacturing PC 
to a target board.

Supported Operating Systems
MS Windows 98SE, Windows NT 4.0 SP6, Windows 2000 SP4, or Win-
dows XP Pro SP1.

Recommended Configuration:
• PC running MS Windows XP Pro SP1
• Pentium III/500-MHz processor or higher
• 128-MB RAM or more
• 10-MB hard disk space (for both application and documentation) 
• Super VGA video adapter
• CD-ROM drive for installation
• Ethernet port

Minimum Configuration:
• PC running MS Windows 98 SE
• Pentium II 233-MHz processor
• 96-MB RAM
• 8-MB hard disk space (application only)
• Super VGA video adapter
• CD-ROM drive for installation

OBSOLETE
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Installation
Perform the following steps to install the software tools:

1. If you downloaded the eZ80Acclaim! Smart Flash Programmer from 
the ZiLOG web site, double-click the installation file and follow the 
on-screen prompts to install the software.

If you received your copy of the eZ80Acclaim! Smart Flash Program-
mer on a CD, double-click the installation file and follow the on-
screen prompts to install the software.

2. DemoShield automatically launches and provides a menu to install 
the product and documentation.

Unless you select a different location, the program is located in the 
Start menu under
Programs > ZiLOG eZ80Acclaim! Smart Flash Programmer <version>

OBSOLETE
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Configuration
Smart Flash Programmer settings are stored in project files. To create a 
project file, the manufacturing engineer specifies a file name and config-
ures the project to support Flash memory programming on a specific 
eZ80Acclaim! target. 

After a project file is created, its advanced configuration can be set up to 
support two Flash programming tasks:

• Programming Hex Files—The engineer specifies one or more Hex 
files containing program instructions or data to be stored in the Flash 
device. For details about creating hex files, refer to the ZiLOG Devel-
oper Studio II—eZ80Acclaim!™ User Manual, UM0144.

• Serialization—If desired, the engineer can specify identifier infor-
mation—such as a serial number or Internet ID—to be stored in the 
Flash device. This can be a single unique value, or an initial value 
configured to increment uniformly as each device is programmed.

A project can be configured to program hex files and serialization at the 
same time, or a separate project can be used for either of these tasks.

The following sections explain how to: 

• Create a project file

• Create a target device description

• Set up the project’s Advanced Configuration

• Use other functions available in the Advanced Configuration window

OBSOLETE
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Create a Project File
The first time you start the eZ80Acclaim! Smart Flash Programmer after 
installation, the Project File Selection window appears (Figure 1). If you 
have already configured projects in the Smart Flash Programmer, it opens 
the project file that was last used.

Figure 1. Smart Flash Programmer – Project File Selection Window

1. If the Project File Creation window is displayed, click New.

If the Project File Creation window is not displayed, click the 
Advanced Configuration button to enable advanced settings, and then 
select New Project from the File menu.

The Project Creation window appears (Figure 2).
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Figure 2. Smart Flash Programmer – Project Creation Window

2. If you want, you can type the path and file name for the new project 
directly into the Project File field, and then skip to step 7.

3. To browse to the new project location, click the  button.

The New Project File Selection window appears (Figure 3).
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Figure 3. Smart Flash Programmer – New Project File Selection 
Window

4. Double-click the folder in which to store the new project. (It is a good 
practice to create a specific folder that holds all projects.)

5. In the File name: field, enter a file name for the new project. Use a 
valid Windows filename. Do not enter an extension.

6. Click Save.

The New Project File Selection Window closes and the Project File 
field in the Project Creation window contains the folder and file name 
specified.

OBSOLETE
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7. Select an eZ80Acclaim! CPU family from the CPU Family: drop-
down menu.

8. Select an eZ80Acclaim! CPU from the CPU: drop-down menu.

9. In the Target Selection list, select the correct description for your tar-
get device (if present), or use the steps in the following section to cre-
ate a new target device description.

Create a Target Device Description
The following steps explain how to create and configure a new target 
description.

To work with existing target descriptions, see "Change Target 
Settings" on page 23.

1. In the Target Selection section of the Project Creation window, dou-
ble-click <New Target>.

If the Project Creation window is not open, you can click the 
Advanced Configuration button to enable advanced settings, and then 
select New Target from the Target menu.

The Target Settings window appears (Figure 4).

Note:

OBSOLETE
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Figure 4. Smart Flash Programmer – Target Settings Window

2. Enter a descriptive name into the Target Name: field. The name must 
be a valid Windows file name (without extension). It is best to use a 
unique name that helps you select the correct target easily. This might 
include the target board model, CPU, and connection type.

3. Verify that the CPU Family and CPU fields contain the correct entries.

4. In the Communications Settings section, select the target’s connection 
type, Serial, Ethernet, or USB.

OBSOLETE
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5. Select additional settings appropriate for the target connection type, 
as follows. See the target board and connector documentation for cor-
rect settings.
– Serial—Select the Port (COM1, COM2, etc.) and Baud Rate.
– Ethernet—Enter the target IP Address. Leave TCP Port at 4040.
– USB—The Serial Number field shows any ZiLOG USB interface 

devices connected to the host PC. If more than one such device is 
connected, select the serial number of the device to be used.

6. If you need to use the alternate ZDI frequency, check the Use Alter-
nate ZDI Frequency check box. See "Communications" on page 36 
for details about this setting.

7. Click .

The Target Clock Settings window appears (Figure 5).
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Figure 5. Smart Flash Programmer – Target Clock Settings Window

8. Specify the frequency of the target system clock in the System Clock 
Frequency (Hz) field.

9. Click .

10. The Target Memory Settings window appears (Figure 6).
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Figure 6. Smart Flash Programmer – Target Memory Settings 
Window

See "Memory" on page 37 for details about memory settings.

11. Configure the External Memory I/O selections:
– Choose a Chip Select Register from the drop-down menu.
– Set the RAM Address Range (hex), if applicable.
– Set the lower and upper Bound (hex).
– Set the Control Register location (hex).
– Set the Bus Mode (hex).

12. Configure Internal Memory selections:
– Check Enable Data RAM, if applicable.
– Check Enable EMAC RAM, if applicable.

Note:OBSOLETE
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– Set the Address Upper Byte (hex), if applicable.
– Set the Flash Address Upper Byte (hex) if you are using internal 

Flash memory.

13. Click .

14. The next Target Flash Memory Settings pane appears (Figure 7).

Figure 7. Smart Flash Programmer – Target Flash Memory Settings 
Window

15. If you are using internal Flash memory, check the Use Internal Flash 
check box.

OBSOLETE
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16. If you are using external Flash memory, select the applicable compo-
nent in the External Flash Memory list. Click the + next to a manufac-
turer name to expand the list. After selecting a component, do the 
following: 
– Specify the External Flash Base Address in hex.
– Select the Number of Units from the drop-down menu.

Only supported Flash memory types are listed. For information on 
programming other Flash memory types, refer to ZDS Command 
Script for the Flash Loader, AN0167.

17. Click .

18. The Target Creation Summary window appears (Figure 8).

Figure 8. Smart Flash Programmer – Target Creation Summary 
Window

Note:

OBSOLETE
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19. Review the displayed settings. To change a setting, click  
until you reach the appropriate target setting window.

20. Click  when you have completed setting up the target.

The Project Creation window reappears. The target you created is 
highlighted in the Target Selection list.

21. Click the OK button in the Project Creation window.

The main Smart Flash Programmer window appears (Figure 9). If 
you have not clicked the Advanced Configuration button, the simpli-
fied programming interface is displayed.

If you want to change target settings after creating the project, see 
"Change Target Settings" on page 23.

Figure 9. Smart Flash Programmer – Main Window

Note:

OBSOLETE
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Set the Advanced Configuration
In the Smart Flash Programmer window, click  to 
enable the advanced configuration interface (Figure 10).

Figure 10. Smart Flash Programmer – Advanced Configuration 
Window

OBSOLETE
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The Advanced Configuration window allows you to:
– Calculate the checksum for a specific hex file. (Flash menu.)
– Specify Flash Files to be programmed. (Project tab.)
– Specify Flash File offsets and erasure. (Project tab.)
– Configure Serialization. (Project tab.)
– Set Flash Info Page options. (Project tab.)
– Change Target settings. (Target tab.)

These tasks are described in the following sections.

The left side of the Advanced Configuration window contains a tabbed 
interface that allows you to select project settings and target hardware 
configuration. "Project Workspace Window" on page 32 provides a refer-
ence for these features.

You may need to resize the Advanced Configuration window to 
see all available tabs and buttons.

Calculate a Flash File Checksum
You can use the following steps to display the checksum of a hex file to 
be loaded into Flash memory. By noting checksums each time you use a 
Flash file, you can make sure the file has not changed since the last time 
you used it.

1. Select Flash --> File Checksum.

The File Checksum Calculator window appears (Figure 11). If a hex 
file is selected in the Project tab, that file’s checksum is displayed 
automatically.

Note:

OBSOLETE
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Figure 11. Smart Flash Programmer – File Checksum Calculator

2. Click the  button and browse to the directory containing the hex 
file for which you wish to calculate a checksum.

3. Select a hex file and click OK.

4. In the File Checksum Calculator window, click the Calculate button.

The checksum for the selected hex file is displayed.

Specify Flash Files To Be Programmed
Use the following steps if this project is to be used for programming hex 
files into the target device.

Flash files are not required for serialization-only operations.

1. Click the Project tab.

The current project file name is displayed in the tab.

2. Click the Flash Files item beneath the project file name.

The right side of the window lists the Flash Files Programming Order.

3. In the Flash Files Programming Order section, click .

The Flash File Selection dialog window appears (Figure 12).

Note:OBSOLETE
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Figure 12. Smart Flash Programmer – Flash File Selection Dialog

4. For each Flash file you want to include, browse to the folder contain-
ing the file, select the file, and then click the OK button. 

You can select multiple files in a folder by holding down the Ctrl or 
Shift key and selecting the files you wish to program.

After you click OK, the selected Flash files are displayed in the list.

You can change the Flash file programming order by clicking a file 
name in the list and then clicking the Up or Down button. To remove 
the selected file from the list, click Remove.

Note:

OBSOLETE
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Set Flash Offset and Erase Options
Use the following steps to set file offset and erase options for the files to 
be programmed.

1. In the Advanced Configuration window, click the Settings item in the 
Project tab.

The Settings section is displayed (Figure 13).

Figure 13. Smart Flash Programmer – Flash File Settings Detail, 
Advanced Configuration Window

2. In the File Offset (Hex): field, enter a hexadecimal file offset value, if 
appropriate. This is the offset from the Flash memory base address 
where Flash file programming begins. All the project’s files are pro-
grammed into this space in the specified programming order.

3. If you want to erase the Flash memory ranges defined in your Target 
settings before programming, select Erase Before Programming.

OBSOLETE
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4. If you want to preserve the Flash memory Info page when the target 
device is erased, Select the Do NOT Erase Info Page button.

Set Up Serialization
1. To display serialization options, select Serialization in the Project tab.

The Serialization section is displayed in the right side of the 
Advanced Configuration window (Figure 14).

Figure 14. Smart Flash Programmer – Serialization Settings Detail, 
Advanced Configuration Window

2. To enable serialization, check Include Serialization in Programming.

3. If you want the serialization value to be stored in the Flash memory 
Info Page, check Place in Info Page.

OBSOLETE
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4. In the Address (Hex): field, enter the Flash memory address where the 
serialization code is to be programmed.

5. In the Serialization Value section, select a radio button to determine 
how the value is displayed and entered. The options are 
– Hexadecimal
– Decimal
– IP Address—Four dotted decimal octets, for example 

192.168.1.30.
– Media Access Control (MAC)—Six hexadecimal bytes separated 

by colons, for example 00:90:23:1C:45:1B.

Regardless of display format, serialization values are always stored as 
a binary value of the specified size.

6. In the Size in Bytes: field, select the number of bytes required to store 
the serialized entry. The sizes available depend on the Serialization 
Value display format.

7. In the Serialization Value text field, enter a unique serial number or a 
starting value for sequential serialization.

If there is a target device attached to your host PC, you can click 
Read Now to read the serial number currently stored in that device.

8. If you want to program unique values into individual parts, you can 
click the Program Serial button now to program the current serializa-
tion value into Flash memory on the currently attached target.

The serialization bytes in Flash memory must be blank (all FFH) for 
Program Serial to succeed. If a hex file is also programmed, it should 
include a blank space for the serial number. If the Erase Before Pro-
gramming setting is selected, the entire Flash memory space is erased 
before programming.

Note:
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9. If you want the serialization value to increment after it is used to pro-
gram each target, enter a value in the Increment Setting text field.

You can select Hexadecimal or Decimal display format for this field. 
To enter a negative (decrement) value, you must select Decimal.

Save the Project in Simple Mode
The Smart Flash Programmer opens a project with the user interface 
(Advanced or Simple) in which it was saved. However, the File-->Save 
Project menu option is hidden in the simple user interface. After creating 
or changing a project, you can use the following steps to save the project 
so it opens in Simple mode by default.

1. Click the Advanced Configuration button to toggle the user interface 
to Simple mode.

2. Select Exit in the File menu.

If you have made changes, a prompt is displayed asking if you want 
to save the project.

3. Click Yes to save the project.

Change Target Settings
Target settings are first made when the target is created (see "Create a Tar-
get Device Description" on page 8.)

To select a different target description for the project, or to copy, rename, 
delete, and create new targets, enable Advanced Configuration (if neces-
sary) and select Manage Targets in the Target menu.

To modify the current target description, click the Target tab in the 
Advanced Configuration window. The Advanced Configuration window 
displays target information (Figure 15). The following options are pro-
vided:

• To change target communication settings, select the Communications 
item in the Target section and change the settings as needed.
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• To change the External Memory I/O and Internal Memory settings, 
select the Memory item in the Target section and change the settings 
as needed.

• To change the Flash Memory settings, select the Flash Memory item 
in the Target section and change the settings as needed.

• To change target clock settings, select the Clock item in the Target 
section and change the settings as needed.

Figure 15. Smart Flash Programmer – Advanced Configuration 
Window, Target Tab
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Other Functions Available in the Advanced Configuration  
Window

There are several other functions available through the Advanced Config-
uration window: Program flash, verify flash, erase flash, and program a 
single, unique value into flash.

Program Flash on an Attached Target
To program Flash on a target device with the currently open project file:

1. Using the interface specified in the project’s Target settings, connect 
your manufacturing PC to the target board that contains the 
eZ80Acclaim! device to be programmed.

2. Click one of the following buttons:

–  – Program the attached target and verify.

–  – Program the attached target, no verification.

Verify Program Stored in Flash on an Attached Target
To verify the program stored in Flash on an attached target, ensure the tar-
get is properly connected and click

 

The status window indicates verification progress. If verification fails, the 
status window displays the failing file and memory location.
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Erase Flash on an Attached Target
To set all bits in Flash on an attached target to 1, ensure the target is prop-
erly connected and click

Writing 1s to all memory locations is considered erasing Flash memory.

Program a Single Value in Flash on an Attached Target
The Program Single Value function is a serialization feature that programs 
a single, unique value into Flash memory on an attached target. Before 
programming a single value, ensure that serialization values for address 
and byte size are properly configured. The serialization byte locations in 
Flash must be blank (all FFH) for Program Single Value to succeed.

To program a single, unique value into Flash on an attached target:

1. Ensure the target is properly connected to the manufacturing PC.

2. Click .

The Program Single Value window appears.

Figure 16. Smart Flash Programmer – Program Single Value Window
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3. Select the mode of entry for the value to be programmed (Hexadeci-
mal, Decimal, IP Address, or MAC Address.

4. Enter the value to be programmed.

5. Click .

The value you entered is programmed into Flash memory on the 
attached target.

You can also read the value programmed into the attached target. To do 
so, ensure the target is attached and click .
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Programming Flash Memory
This section describes a suggested Flash programming workflow for man-
ufacturing use. This section is designed to be removed from the manual 
and used to assemble a custom set of manufacturing test instructions.

The basic steps for using the Smart Flash Programmer are:

• Connect the manufacturing PC to the target board using a ZiLOG 
ZPAK II cable, Ethernet cable, or USB Smart Cable. Refer to your 
manufacturing test instructions for connection details.

• Start the Smart Flash Programmer and load the correct Flash project 
file.

• Flash the target board.

• Disconnect the target board and connect another.

Program Flash on an Attached Target
To program Flash on a target device with the currently open project file 
and automatically verify that Flash was properly programmed:

1. Connect your manufacturing PC to the target board containing the 
eZ80Acclaim! device to be programmed.

2. Open the File menu and click Open. A file selection window appears. 
Select the project file to be programmed and click Open.

3. Click .

The status window indicates programming and verification status. If 
verification fails, the status window indicates the file that failed and 
the associated memory location.

4. When the status window indicates that verification is complete, dis-
connect the target board and connect a new target board.

5. Repeat Steps 2 through 4.
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Fast Program Flash on an Attached Target
The Fast Program function programs Flash on a target device with the 
open project file. No verification is performed. To fast program Flash on a 
target device:

1. Connect your manufacturing PC to the target board containing the 
eZ80Acclaim! device to be programmed.

2. Open the File menu and click Open. A file selection window appears. 
Select the project file to be programmed and click Open.

3. Click .

The status window indicates programming status.

4. When the status window indicates that programming is complete, dis-
connect the target board and connect a new target board.

5. Repeat Steps 2 through 4.

Verify Program Stored in Flash on an Attached Target
To verify the program stored in Flash on an attached target, ensure the tar-
get is properly connected and click . 

The status window indicates whether the verification was successful. If 
verification fails, the status window indicates the file that failed and the 
associated memory location.

Erase Flash on an Attached Target
To set all bits in Flash memory on an attached target to 1, ensure the target 
is properly connected and click .

Writing 1s to all memory locations is considered erasing Flash memory.
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Program a Single Value in Flash on an Attached Target
The Program Single Value function is a serialization feature that programs 
a single, unique value into Flash memory on an attached target. Before 
programming a single value, ensure that serialization values for address 
and byte size are properly configured, since they are used to determine the 
memory location for the single value.

To program a single, unique value into Flash on an attached target:

1. Ensure the target is properly connected to the manufacturing PC.

2. Click .

The Program Single Value window appears.

Figure 17. Smart Flash Programmer – Program Single Value Window

3. Select the format of entry for the value to be programmed (Hexadeci-
mal, Decimal, IP Address, or MAC Address.

4. Click .

The value you entered is programmed into Flash memory on the 
attached target at the memory location specified in Serialization set-
tings.
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You can also read the value programmed into the attached target. To do 
so, ensure the target is attached and click . The Smart Flash 
Programmer returns the value of the data stored in the location defined by 
the Serialization settings.

Starting the Smart Flash Programmer from a Command Line
You can run the Smart Flash Programmer from a Windows command line 
and use command-line switches to specify what it does on startup.

Command syntax:
c:\[installation_path]\bin\zdsflash [<project_file>]|[-s] [-l <log_file>][-h]

Switches:

• <project_file> – Specify a project file name to load

• -s – Cause the Smart Flash Programmer to display the project selec-
tion dialog on startup.

• -l <log_file> – Change the name of the default log file created for the 
new session.

• -h – Display a usage summary for the Smart Flash Programmer com-
mand line launch options.

For example, to load the project file c:\flash_files\my_project.zfpproj 
from the command line, enter:

c:\[installation_path]\bin\zdsflash c:\flash_files\my_project.zfpproj
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Project Workspace Window
The Project Workspace window on the left side of the Advanced Configu-
ration window has two tabs. The Project tab allows you to view and/or 
change the Flash details, Flash files, general settings, and serialization 
settings. The Target tab allows you to view and/or change the target 
details, communications settings, memory settings, Flash memory set-
tings, and clock settings.

Project Tab
The Project tab of the Project Workspace window allows you to view and/
or change the following:

• Flash Details

• Flash Files

• Settings

• Serialization

To use the Project Options right-click menu, click on the right button of 
your mouse anywhere in the Project Workspace window.

The Project Options right-click menu allows you to do the following:

• Create a new project

• Open an existing project

• Save your project

• Save a copy of your project with a new name

Flash Details
Click on the project name in the Project tab of the Project Workspace win-
dow to display the Flash Details window.

OBSOLETE

OBSOLETE
Using the eZ80Acclaim!™ Smart Flash Programmer UM017702-0105



eZ80Acclaim!™ Smart Flash Programmer
User Manual

33
The Flash Details window lists the CPU family, selected Flash files, 
whether Flash memory will be erased before programming, file offset, 
whether to include the serial number with programming, serialization 
address, serialization number, serialization size in bytes, serialization 
increment, whether to erase the info page, and whether to use the info 
page with serialization.

The Flash Details right-click menu allows you to copy selected text or to 
select all text in the Flash Details window.

Flash Files
Click on the Flash Files item in the Project tab of the Project Workspace 
window to display the Flash Files window.

The Flash Files window lists the Flash files in the order that they will be 
programmed. 

Click Add to navigate to the location of a Flash file to be programmed.

Click Remove to delete the selected Flash file.

Click Up to move the selected Flash file to an earlier time slot.

Click Down to move the selected Flash file to a later time slot.

Use the Flash Files right-click menu to display the File Checksum Calcu-
lator.

Settings
Click on the Settings item in the Project tab of the Project Workspace 
window to display the Settings window.

1. In the File Offset (Hex): field, enter a hexadecimal file offset value, if 
appropriate. This value applies to every file in the project’s Flash 
Files list.

2. If you want to erase the Flash memory range defined in your Target 
settings before programming, check Erase Before Programming.
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3. If you want to preserve the Flash memory Info page when the target 
device is erased, Select the Do NOT Erase Info Page button.

Serialization
Click on the Serialization item in the Project tab of the Project Workspace 
window to display the Serialization window.

1. To enable serialization, check Include Serialization in Programming.

2. If you want the serialization value to be stored in the Flash memory 
Info Page, check Place in Info Page.

3. In the Address (Hex): field, enter the Flash memory address where the 
serialization code is to be programmed.

4. In the Serialization Value section, select a radio button to determine 
how the value is displayed and entered. The options are 
– Hexadecimal
– Decimal
– IP Address—Four dotted decimal octets, for example 

192.168.1.30.
– Media Access Control (MAC)—Six hexadecimal bytes separated 

by colons, for example 00:90:23:1C:45:1B.

Regardless of display format, serialization values are always stored as 
a binary value of the specified size.

5. In the Size in Bytes: field, select the number of bytes required to store 
the serialized entry. The sizes available depend on the Serialization 
Value display format.

6. In the Serialization Value text field, enter a unique serial number or a 
starting value for sequential serialization.

If there is a target device attached to your host PC, you can click 
Read Now to read the serial number currently stored in that device.
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7. If you want to program unique values into individual parts, you can 
click the Program Serial button now to program the current serializa-
tion value into Flash memory on the currently attached target.

8. If you want the serialization value to increment after it is used to pro-
gram each target, enter a value in the Increment Setting text field.

You can select Hexadecimal or Decimal display format for this field. 
To enter a negative (decrement) value, you must select Decimal.

Target Tab
The Target tab of the Project Workspace window allows you to view and/
or change the following:

• Target Details

• Communications

• Flash Memory

• Clock

To use the Target Options right-click menu, click on the right button of 
your mouse anywhere in the Project Workspace window.

The Target Options right-click menu allows you to do the following:

• Create a new target

• Save your target

• Display the Target Manager

Target Details
Click on the target name in the Target tab of the Project Workspace win-
dow to display the Target Details window.

The Target Details window lists the target name, CPU family, CPU name, 
communication type, baud rate, serial port, and clock frequency.

OBSOLETE

OBSOLETE
UM017702-0105 Using the eZ80Acclaim!™ Smart Flash 



eZ80Acclaim!™ Smart Flash Programmer
User Manual

36
The Target Details right-click menu allows you to copy selected text or to 
select all text in the Target Details window.

Communications
Click on the Communications item in the Target tab of the Project Work-
space window to display the Communications window.

The Communications window allows you to select the communications 
type, port, and baud rate.

Select the Use Alternate ZDI Clock Frequency check box if you want to 
use the ZDI clock frequency. The Smart Flash Programmer uses the infor-
mation in the following table to make the ZDI clock frequency selection:

If a reliable connection cannot be established and the system clock fre-
quency is within an overlapping area, you can override the default choice 
by selecting the Use Alternate ZDI Clock Frequency check box. Selecting 
the alternate system clock table changes the ZDI clock frequency used by 
the Smart Flash Programmer. For instance, if the system clock is 20 MHz, 
the 4-MHz ZDI clock rate might prove to be more reliable than the 8-
MHz rate.

ZDI Clock Frequency System Clock Frequency (alternate)
1 MHz 3- 8 (3-10) MHz
2 MHz 8-12 (10-16) MHz
4 MHz 12-20 (16-24) MHz
8 MHz 20-50 (24-50) MHzOBSOLETE

OBSOLETE
Using the eZ80Acclaim!™ Smart Flash Programmer UM017702-0105



eZ80Acclaim!™ Smart Flash Programmer
User Manual

37
Memory
Click on the Memory item in the Project tab of the Project Workspace 
window to display the Memory window.

The Smart Flash Programmer writes the initialization parameters to the 
target while the connection is being established. This allows for a virtual 
reset condition to be created using the following: 

1. Choose a chip select register from the Chip Select Registers drop-
down list box.The chip select registers control the type of access, 
address bounds, and wait state assertion.

2. Enter the lower bound for the chip select register in the Lower Bound 
(hex) field.

3. Enter the upper bound for the chip select register in the Upper Bound 
(hex) field.

4. Enter the control register in the Control Register (hex) field.

5. Enter the bus mode in the Bus Mode (hex) field.

6. Select the Enable Data RAM check box to enable the general-purpose 
internal RAM block. Enter the address in the Address Upper Byte 
(hex) field.

7. Select the Enable EMAC RAM check box to enable the Ethernet 
Media Access Controller’s internal RAM. Enter the address in the 
Address Upper Byte (hex) field.

8. Select the Enable Flash check box if you want to use internal Flash. 
Enter the address in the Address Upper Byte (hex) field. This shifts 
Flash.

Flash Memory
Click on the Flash Memory item in the Target tab of the Project Work-
space window to display the Flash Memory window.

The Flash Memory window allows you to check the Flash memory map.
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Clock
Click on the Clock item in the Project tab of the Project Workspace win-
dow to display the Clock window. Enter the frequency in the System 
Clock Frequency (Hz) field.

Status Window
The Status window displays messages to indicate when actions are com-
pleted, warnings, and errors.
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Customer Feedback
If you note any inaccuracies while reading this User Manual, please copy and complete this form, 
then send it to ZiLOG (http://support.zilog.com). We also welcome your suggestions!
Product Information

Customer Information

Problem Description or Suggestion
Provide a complete description of the problem or your suggestion. If you are reporting a specific 
problem, include all steps leading up to the occurrence of the problem. Attach additional pages as 
necessary.

eZ80Acclaim!™ Smart Flash 
Programmer
Serial # or Board Fab #/Rev. #
Software Version
Document Number
Host Computer Description/Type

Name Country
Company Phone
Address Fax
City/State/Zip E-Mail
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