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Introduction
This quick start guide helps you to get started with Zilog Real-Time Kernel (RZK) soft-
ware for application development on Zilog’s eZ80Acclaim!® family of microcontrollers 
and microprocessors. This document guides you through the following tasks:
• RZK Overview
• Supported Target Hardware 
• Supported Host Environments
• Installing RZK 
• RZK Directory Structure
• Creating and Executing an RZK Project
• Related Documentation

RZK Overview
RZK is a real-time, preemptive, and multitasking kernel designed for time-critical, embed-
ded applications. It is currently available for Zilog’s eZ80® product line. RZK is supplied 
as a C library module. Figure 1 displays the RZK architecture RZK.

Figure 1. Zilog Real-Time Kernel Architecture
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Real-time applications are linked with the RZK library during compilation. The execut-
able files of the real-time application are downloaded to a target platform, or placed in 
ROM.

RZK contains kernel modules, which are referred to as RZK objects. RZK objects used for 
real-time application development are listed below: 
• Threads 
• Timers 
• Semaphores 
• Event groups 
• Interrupts 
• Message queues 
• Regions and partitions 
• Device driver framework
• Board Support Package (WLAN, USB, EMAC, UART, I2C, SPI, and RTC drivers)

For more information about these RZK objects, refer to the Zilog Real-Time Kernel User 
Manual (UM0075), which is available free for download from the Zilog website and can 
also be found in the following filepath:

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\Docs 

Throughout this document, X.Y.Z represents the RZK version number in 
Major.Minor.Revision format, and A.B.C represents the ZDS II – eZ80 
Acclaim! version number in Major.Minor.Revision format..

Supported Target Hardware
RZK supports the eZ80Acclaim!® family of Flash MCUs, which includes the eZ80F91, 
eZ80F92, and eZ80F93 MCUs. It also supports the eZ80L92 MPU, an eZ80® micropro-
cessor. Zilog provides development kits for each of these processors; refer to the docu-
mentation provided with each development kit for setup and configuration instructions.

Note:
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Supported Host Environments
To use your eZ80Acclaim!® development kit with RZK, your host system must meet the 
minimum hardware and software requirements specified in the readme file contained in 
your development kit’s ZDS II installation. 

Installing RZK
Zilog offers two options for installing the Zilog Real-Time Kernel: choose Option 1 if you 
will be installing the ZDS II – eZ80Acclaim! software from the CD included with your 
eZ80Acclaim! development kit, and choose Option 2 if you will be downloading and 
installing the most recent version of ZDS II – eZ80Acclaim! from the zilog.com website.

Option 1. RZK is automatically installed when you install the Zilog Developer Studio II – 
eZ80Acclaim! software from the kit CD. For information about installing ZDS II in this 
manner, please refer to the Zilog Developer Studio II - eZ80Acclaim! User Manual 
(UM0144).

Option 2. Zilog software, including RZK, is available from the zilog.com website. Before 
downloading, however, you will need to create an account by clicking the Register link 
that appears underneath the Username/Password prompts in the upper left corner of most 
pages on the site. If you have already registered on zilog.com, simply log in with your 
username and password, then navigate via the Tools and Software menu to Software 
Downloads. In the left panel, listed under Software Category, click ZDS II and Utility 
Tools. Next, scroll to the ZDS2_eZ80Acclaim section and click the Download link for the 
latest version of the ZDS II – eZ80Acclaim! software, which includes the most recent ver-
sion of RZK.

Uninstalling RZK
To uninstall RZK, launch the InstallShield Wizard. When the InstallShield Wizard finds 
an already-installed version of RZK, it allows you to modify, repair or remove the previ-
ous installation of RZK.

As an alternative, navigate via the Windows Start menu to Settings → Control 
Panel → Add and Remove Programs to select the installed version of RZK from the 
list.

The Installing RZK and Uninstalling RZK sections are applicable only for 
RZK version 2.2.0 and earlier versions.

Note:
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RZK Directory Structure
Figure 2 displays the directory structure created in the host PC when you install RZK. By 
default, the installation directory is: 

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib.

Table 1 describes the contents of important folders in the RZK directory. Each folder con-
tains subfolders for the RZK Core, Board Support Package (BSP) and Zilog File System.

Figure 2. RZK Directory Structure
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Hardware Requirements
The hardware required to execute the sample application using RZK include:
• eZ80 Development Platform with eZ80Acclaim!® Module installed
• Target Interface Module (TIM)
• ZPAK II/Serial Smart Cable/USB Smart Cable

Table 1. RZK Directory Contents 

Folder in RZK File Type Description

\Conf C and Assembly 
source files

This folder contains the required and optional 
RZK configuration files for inclusion in the 
application project workspace.

\Inc Header files RZK header files required for inclusion in the 
application project workspace.

\Lib Library files RZK library files required for inclusion in the 
application project workspace. Lib folder 
contains the following library files:
RZKDebugPI.lib: debug, priority inheri-
tance
RZKDebugNPI.lib: debug, no priority inher-
itance
RZKNDebugPI.lib: no debug, priority inher-
itance
RZKNDebugNPI.lib: no debug, no priority 
inheritance
RZKeZ80xxx.lib for ZDS II: target-related 
support file, where xxx refers to the platform; 
F91, F92, F93, or L92. 
Contains BSP libraries, BSPeZ80xxx.lib, 
where xxx refers to the platform; F91, F92, 
F93, or L92. 
Also contains stub files for EMAC driver, 
NOEmac.obj, and Zilog File System.

\Docs This folder contains RZK-related documents, including this quick 
start guide.

\SamplePrograms\
Core

Project workspace, 
application

Sample application project workspace.
QS004815-1211 Page 5 of 15



Zilog Real-Time Kernel
Quick Start Guide
• One RS-232 cable
• Two RJ-45 Ethernet cables
• Two COM ports on the PC
• USB/Serial Smart Cable 

Software Requirements
The software required to execute the sample application using RZK include:
• Windows operating system
• ZDS II – eZ80Acclaim!®

• HyperTerminal application

Hardware Setup
Figures 3 and 4 display the hardware setup.

Figure 3. Hardware Setup Using an Ethernet Hub and ZPAK II

Figure 4. Hardware Setup Using a Serial Smart Cable/USB Smart Cable
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Observe the following steps to set up the hardware:

1. Set the jumper pin connections on the eZ80 Development Platform to their default 
settings.

2. Connect the power supply (9 V) cables to the eZ80 Development Platform.

3. If you’re using ZPAK II, observe the following brief procedure; if you’re using either 
of the Serial or USB smart cables, skip ahead to Step 4.

a. Connect the ZDI target interface module to the ZDI J4 port on the eZ80® 
Development Platform.

b. Connect one end of the RJ-45 cable to the Ethernet port on the ZPAK II unit and 
the other end to the LAN (required if debugging with ZDS II).

c. Connect the power supply (5 V) to the ZPAK II unit.

4. If you’re using a Serial or USB Smart Cable, follow either of the following proce-
dures:

– Serial Smart Cable: Connect the ZDI target interface module of the Serial Smart 
Cable to the ZDI J4 port on the eZ80 Development Platform, and connect the 
other end to the serial port on the host PC.

– USB Smart Cable: Connect the ZDI target interface module of the USB Smart 
Cable to the ZDI J4 port on the eZ80 Development Platform, and connect the 
other end to the USB port the on host PC.

5. Connect one end of the RJ-45 cable to the Ethernet port on the eZ80 Module and the 
other end to the LAN.

6. Connect the RS-232 cable to the eZ80 Development Platform and to the COM1 port 
of the development PC.

Before using RZK, ensure that the host and target system requirements are 
met and that the software is installed.

Configuring the HyperTerminal Application
Observe the following steps to configure the HyperTerminal application:

Note:
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1. Launch the HyperTerminal application by navigating via the Windows Start menu to 
Programs → Accessories → Communications → HyperTerminal. The 
Connection Description dialog box is displayed.

2. Enter the name for a new connection in the Connection Description dialog, and click 
OK to open the Connect To dialog box.

3. In the Connect Using text field, select the port (COM1 or COM2) to which the serial 
cable is connected. Click OK to open the Port Settings dialog box for the selected 
port.

4. In the Port Settings dialog box, enter the values listed in Table 2 into their respective 
text fields:

5. Click OK to establish connection to the eZ80 Development Platform using the serial 
port.

6. Press the RESET button on the eZ80 Development Platform.

Creating and Executing an RZK Project
After installing ZDSII_eZ80Acclaim!_A.B.C, open the sample software projects for RZK. 
These sample projects are available in the following filepath:

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\SampleProgram\Core

The RAM, FLASH and COPY_TO_RAM project configurations are provided with all of 
the sample applications, and can be readily used for new applications by removing the 
application files and adding your own application files. 

A sample application written for RZK forms a part of the setup installation files. This sec-
tion discusses the setup and the procedure to execute the sample application in the ZDS II 
Development Environment for the eZ80F91 MCU only. For other platforms, a similar pro-

Table 2. HyperTerminal Port Settings

Bits per second 57600 bps

Data bits 8

Parity None

Stop Bits 2

Flow control None 
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cedure, also listed in this section, must be followed. The sample RZK application is 
located in the following path:

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\SampleProgram\
Core\routerApp

The following steps are intended for creating project workspaces only in the 
ZDS II environment. For programming guidance, refer to the Zilog Real-
Time Kernel Reference Manual (RM0006). This section lists only those files 
and settings that must be modified to be compatible with RZK. For informa-
tion about creating a project workspace, refer to the Zilog Developer Studio 
II – eZ80Acclaim! User Manual (UM0144).

Observe the following steps to create and execute an RZK project using ZDS II:

1. After creating the project workspace, add all of the files listed in the RZK 
Configuration section of the Zilog Real-Time Kernel User Manual (UM0075) to the 
project workspace by selecting Add Files from the Project Menu.

2. Add all of the user application files to the project workspace.

3. Navigate via the Project menu to Settings → C. The Project Settings dialog box is 
displayed.

4. In the Code Generation tab, select the Size or Speed option from the Optimize For 
drop-down list, as appropriate. Check the Limit Optimizations for Easier Debug-
ging option.

5. In the Preprocessor tab of the Project Settings dialog box, add the macro defini-
tions listed in the RZK Configuration section of the Zilog Real-Time Kernel User 
Manual (UM0075) to the Preprocessor Definitions field. 

Do not enable ZSL. RZK does not support the ZSL provided by ZDS II. Select-
ing PORTS or UART from the ZDS II Menu → Project → Settings → ZSL 
navigation does not initialize the peripherals. You must initialize these periph-
erals using the RZK device driver APIs.

6. In the Linker Settings category (for the COPY_TO_RAM configuration), add the 
linker directives by checking the Additional Directives option, then click Edit. The 

Note:

Note:
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Additional Linker Directives dialog box is displayed. Add the following statement, 
then click OK:

CHANGE TEXT is CODE

7. In the Linker’s Address Spaces field, provide the required memory ranges for RAM 
and ROM.

8. In the Linker’s Output field, select the Intel Hex32–Records output option to gener-
ate a hex image for the FLASH and COPY_TO_RAM configurations.

9. In the Debugger tab, select the eZ80DevPlatform_F91_Flash target for the FLASH 
and COPY_TO_RAM configurations (ZPAK II must be connected to the eZ80 Develop-
ment Platform). For the RAM configuration, select the eZ80DevPlatform_F91_RAM 
target. Select the appropriate debug tool from the Debug Tool → Current drop-down 
list and click OK. For information about performing this step, refer to the Zilog Devel-
oper Studio II – eZ80Acclaim! User Manual (UM0144).

10. Rebuild the application by selecting Build → Rebuild All.

11. Download the application to the target by selecting Debug → Download Code. 
Select Debug → Go to execute the application.

12. After burning the application hex image, press the RESET button on the eZ80 Devel-
opment Platform to execute the application.

Building and Running the Sample RZK Project
The sample project provided with the kit is a router application, located in the following 
filepath:

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\SamplePrograms\
Core\routerApp

Observe the following steps to execute this router application:

1. Establish the hardware connections displayed in Figure 3 on page 6. 

2. Launch ZDS II by navigating via the Windows Start menu to Programs → Zilog 
ZDS II – eZ80Acclaim!_<Version> → ZDS II – eZ80Acclaim!_<Version>. 

3. From the File menu in ZDS II, select Open Project, and navigate to the following file-
path: 
QS004815-1211 Page 10 of 15

http://www.zilog.com/docs/devtools/um0144.pdf
http://www.zilog.com/docs/devtools/um0144.pdf


Zilog Real-Time Kernel
Quick Start Guide
<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\SamplePrograms\
Core\routerApp

Select the routerApp_xxx.zdsproj project (in which xxx refers to the F91, F92, 
F93 or L92 platform) located in the above filepath. Click Open. A list of source files 
appears in the Workspace panel.

4. Select the RAM, FLASH or COPY_TO_RAM configuration from the Build → Set 
Active Configuration menu.

5. Select Settings from the Project menu in ZDS II. The Project Settings dialog box is 
displayed.

6. In the Debugger tab, select the appropriate debug tool from the Debug Tool → 
Current drop-down list and click OK. 

7. Select Rebuild All from the Build menu to rebuild your project.

8. After the build is complete, press the RESET button on the eZ80 Development Plat-
form.

9. For the RAM configuration, download the application code by selecting 
Debug → Download Code. 

10. To execute the application, select Debug → Go.

11. For FLASH or COPY_TO_RAM configurations, burn either of the 
routerApp_xxx_Flash.hex or routerApp_xxx_Copy_To_Ram.hex image files 
into Flash memory using the integrated Flash Loader feature of ZDS II by performing 
the following steps:
a. Select Tools  Flash Loader to open the Flash Loader dialog box.
b. Select routerApp_xxx_Flash.hex or routerApp_xxx_Copy_To_Ram.hex, 

both of which are located in the following path:

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\
SamplePrograms\Core\routerApp

c. Click Erase, then click Fast Burn to write the application image into Flash 
memory.

d. Click Close to close the Flash Loader dialog box.
e. Press the RESET button on the eZ80 Development Platform. The output, which 

will be similar to the example shown below, is displayed in the HyperTerminal 
application.
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processing.......
SOURCE BUFFER:
0RZK REAL TIME1RZK REAL TIME2RZK REAL TIME3RZK REAL TIME4RZK 
REAL TIME
5RZK REAL TIME6RZK REAL TIME7RZK REAL TIME8RZK REAL TIME9RZK 
REAL TIME
:RZK REAL TIME;RZK REAL TIME<RZK REAL TIME=RZK REAL TIME>RZK 
REAL TIME
?RZK REAL TIME

DESTINATION BUFFER:

0RZK REAL TIME1RZK REAL TIME2RZK REAL TIME3RZK REAL TIME4RZK 
REAL TIME
5RZK REAL TIME6RZK REAL TIME7RZK REAL TIME8RZK REAL TIME9RZK 
REAL TIME
:RZK REAL TIME;RZK REAL TIME<RZK REAL TIME=RZK REAL TIME>RZK 
REAL TIME
?RZK REAL TIME
Entry count = 1
Application successful
processing.......

SOURCE BUFFER:
0RZK REAL TIME1RZK REAL TIME2RZK REAL TIME3RZK REAL TIME4RZK 
REAL TIME
5RZK REAL TIME6RZK REAL TIME7RZK REAL TIME8RZK REAL TIME9RZK 
REAL TIME
:RZK REAL TIME;RZK REAL TIME<RZK REAL TIME=RZK REAL TIME>RZK 
REAL TIME
?RZK REAL TIME

DESTINATION BUFFER:

0RZK REAL TIME1RZK REAL TIME2RZK REAL TIME3RZK REAL TIME4RZK 
REAL TIME
5RZK REAL TIME6RZK REAL TIME7RZK REAL TIME8RZK REAL TIME9RZK 
REAL TIME
:RZK REAL TIME;RZK REAL TIME<RZK REAL TIME=RZK REAL TIME>RZK 
REAL TIME
?RZK REAL TIME
Entry count = 2
Application successful
:
:
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Creating a New RZK Project
To create a new RZK project, copy an existing sample project into a new directory and 
modify it to suit your requirements. For information about how to add and remove files 
from a project and for a description of the advanced features of ZDS II, refer to the Zilog 
Developer Studio II – eZ80Acclaim! User Manual (UM0144). For a information about 
creating new projects and the settings required for RAM projects, refer to the Zilog Real-
Time Kernel User Manual (UM0075).

Observe the following steps to create a new RZK project called MyRZKApp from an exist-
ing RZK application called RouterApp: 

1. Navigate to the following filepath:

<ZDS Install DIR>\<RZK Install Dir>\RZK\SamplePrograms\Core\
RouterApp

In this path, <ZDS Install Dir> is platform-dependent, as follows:

– For 32-bit Windows platforms, <ZDS Install Dir> = C:\Program Files\
Zilog\ZDSII_eZ80Acclaim!_A.B.C

– For 64-bit Windows platforms, <ZDS Install Dir> = C:\Program Files 
(x86)\Zilog\ZDSII_eZ80Acclaim!_A.B.C

– Additionally, <RZK Install Dir> = ZTP\ZTPX.Y.Z_Lib

2. Copy the routerApp_xxx.zdsproj file by right-clicking on the file and selecting 
Copy from the pop-up menu.

3. Navigate to <ZDS Install DIR>\<RZK Install Dir>\RZK\SamplePro-
grams\Core and create a new folder named MyProject by right-clicking any empty 
space within the folder window and selecting New → Folder from the pop-up menu.

4. Double-click the MyProject folder to enter the new folder that you created in the pre-
vious step.

5. Right-click on any empty space in the folder window and select Paste from the pop-
up menu. Optionally, right-click the routeApp_xxx.zdsproj file that you copied to 
the MyProject folder and select Rename from the pop-up menu. Enter a new name for 
the project; for example, MyRZKApp.zdsproj.

6. Launch ZDS II by navigating from the Start menu to Programs → Zilog → ZDS II – 
eZ80Acclaim!_<Version> → ZDS II–eZ80Acclaim!_<Version>. 
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7. In ZDS II, click File → Open Project, and navigate to the location of the project file 
shown in Step 6.

8. Remove the source files that appear in the Workspace window by right-clicking each 
file and selecting Remove Selected File(s) from the pop-up menu.

9. Create new source files that implement your application.

10. Build the project by executing the steps listed in the Building and Running the Sample 
RZK Project section on page 10. Be sure to substitute the appropriate path and appli-
cation project name.

Related Documentation
By default, the RZK documentation directory is installed in the following path: 

<ZDSII installed directory>\Program Files\Zilog\
ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib\RZK\Docs

The Docs folder contains the following documents related to RZK. Each of these docu-
ments is also available free for download from the Zilog website.
• Zilog Real-Time Kernel User Manual (UM0075)
• Zilog Real-Time Kernel Reference Manual (RM0006)
• Zilog Real-Time Kernel Product Brief (PB0155)
• Zilog File System Reference Manual (RM0039)
• Zilog File System User Manual (UM0179)
• Zilog File System Quick Start Guide (QS0050)
• RZK – ZDS II Release Notes

The following documents apply to all eZ80Acclaim! devices, and are available free for 
download from the Zilog website.
• eZ80 CPU User Manual (UM0077)
• Zilog Developer Studio II – eZ80Acclaim! User Manual (UM0144)
• ZPAK II Debug Interface Tool Product User Guide (PUG0015)
• eZ80 C Compiler User Manual (UM0055)
• eZ80Acclaim! External Flash Loader Product User Guide (PUG0016)
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Customer Support

To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at 
http://support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base at http://
zilog.com/kb or consider participating in the Zilog Forum at http://zilog.com/forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com.

DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY

ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL 
COMPONENTS IN LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE 
EXPRESS PRIOR WRITTEN APPROVAL OF THE PRESIDENT AND GENERAL 
COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for use 
provided in the labeling can be reasonably expected to result in a significant injury to the user. A critical 
component is any component in a life support device or system whose failure to perform can be reasonably 
expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2011 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, or 
technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES NOT 
ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED IN 
ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED HEREIN OR 
OTHERWISE. The information contained within this document has been verified according to the general 
principles of electrical and mechanical engineering. 

eZ80 and eZ80Acclaim! are trademarks or registered trademarks of Zilog, Inc. All other product or service 
names are the property of their respective owners.

Warning:
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