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LIFE SUPPORT POLICY
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use provided in the labeling can be reasonably expected to result in a significant injury to the user. A criti-
cal component is any component in a life support device or system whose failure to perform can be reason-
ably expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer

©2015 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, 
or technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES 
NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED 
IN ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED 
HEREIN OR OTHERWISE. The information contained within this document has been verified according 
to the general principles of electrical and mechanical engineering. 

Z8051 is a trademark or registered trademark of Zilog, Inc. All other product or service names are the 
property of their respective owners. 
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Introduction

Zilog’s Z8051 On-Chip Debugger II (OCD II) application has been developed to support 
Zilog’s Z8051 MCUs when application development will occur on PCs. This document 
describes how to set up and use the Z8051 OCD II program with your Z8051 Development 
Kit.

The Z8051 OCD II enables a development PC to communicate with your target Z8051-based 
MCU; its interface dongle (Z51FOCD2000ZACG) is used to connect this development PC 
to the Z8051 MCU. The OCD II controls the Z8051 MCU’s internal debugging logic includ-
ing emulation, step run, monitoring, etc., and can read or change the value of the Z8051 
MCU’s internal memory and I/O peripherals.

The Z8051 OCD II supports emulation and debugging at the maximum frequency of the MCU, 
thereby eliminating the requirement for an expensive emulator system.

The Z8051 OCD II Debugger works with the Microsoft Windows XP, Vista (32/64) and 
Windows 7 (32/64) operating systems. An example On-Chip Debugger II screen is shown 
in Figure 1.

Figure 1. On-Chip Debugger II Screen
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On-Chip Debugger I Software and MCUs

Zilog’s On-Chip Debugger I (OCD I) software, formerly referred to simply as OCD soft-
ware, controls the OCD I dongle that is connected to each OCD I-compatible MCU. This 
dongle is the original OCD I interface module that bridges the OCD I software to all 
OCD I-compatible MCUs.

The following OCD I-compatible MCUs utilize the OCD I dongle and software:

• Z51F6412

• Z51F3221

• Z51F3220

• Z51F0811

On-Chip Debugger II Software and MCUs

The On-Chip Debugger II (OCD II) software also controls the OCD I dongle that is con-
nected to each OCD I-compatible MCU. Additionally, the OCD II software controls the 
OCD II dongle, which connects to all OCD I or OCD II MCUs. This dongle is an OCD II 
interface module that bridges the On-Chip Debugger II software to all OCD I-compatible 
and OCD II-compatible MCUs.

The Z51F0420 OCD II-compatible MCU utilizes the OCD II dongle and software.

Figure 2 shows the compatibility between Z8051 devices and software/OCD type inter-
face.

Figure 2. Device, Software, and OCD Type Interface Compatibility
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OCD II Features

The key features of the Z8051 On-Chip Debugger II are:

• Supports Zilog’s 8-bit Z8051 Family of MCUs

• Support for OCD I and OCD II MCUs and interface modules

• Loads HEX and map/symbol files

• Allows symbolic debugging

• Supports the internal code memory of the target MCU

• Displays code space using a disassembler

• Supports line assembly functions

• Toggles Program Counter (PC) breakpoints

• Supports the display and modification of RAM, Sfr, registers, etc.

• Displays code, Xdata area using dump format

• Device autodetect:

– Device configuration is not required

• Operating frequency:

– Supports the maximum frequency of the target MCU

• Operating voltage:

– Supports the entire voltage range of the target MCU

• Clock source:

– Supports all XIN, internal/external RCs, etc.

• Display emulation clock:

– Counts and displays executed machine cycles

• Emulation and debugging:

– Supports free run, step run, autostep run, etc.

• Save and load the development environment 
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Install the Z8051 OCD II Software and 
Documentation

The Z8051 On-Chip Debugger II (OCD II) interface is the interface by which your PC will 
communicate with the Z8051 MCU to download and execute code. In addition to the 
OCD II, software such as development tools and sample applications will be installed.

If you followed the procedure on the paper insert in your kit and have already installed the 
Z8051 software and documentation, skip this section and proceed to the Z8051 OCD II 
Driver Installation section on the next page.

Observe the following procedure to install the Z8051 On-Chip Debugger II software and 
documentation on your computer.

1. Ensure that the OCD II interface hardware is not connected to your PC.

2. In a web browser, download the Z8051 Software and Documentation v2.2 or later 
from the Zilog Store. When the download is complete, unzip the file to your hard 
drive and double-click to launch the installation file named 
Z8051_<version_number>.exe.

In this filename, <version_number> refers to the version number of the OCD II Software 
and Documentation release. For example, this version number may be 2.2.

3. Follow the on-screen instructions to complete the OCD II software installation.

Z8051 OCD II Driver Installation

The driver programs for the Z8051 On-Chip Debugger II are copied during the software 
and documentation installation. In the following procedure for PCs running Windows 7 
32- and 64-bit operating systems, ensure that the target side of the OCD II will remain 
unconnected while you install these drivers. 

If you are running Windows Vista, see Appendix A on page 59 to install your device driv-
ers. If you are running Windows XP, see Appendix B on page 62.

Note:

Note:

Note:
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1. Connect the OCD II hardware to the USB port of your PC by connecting the A (male) 
end of one of the two USB A (male)-to-Mini-B cables with the host PC’s USB port. 
Connect the Mini-B end to the OCD II device.

2. After the PC detects the new hardware, it will display the Installing device driver soft-
ware dialog shown in Figure 3.

3. Select Browse my computer for driver software (advanced) to display the dialog 
shown in Figure 4, which prompts you to key in or browse for the location of the .inf 
file. Depending on the type of computer you use (32- bit or 64-bit), use the Browse 
button to navigate to one of the following paths, then click the Next button.

– On OCD I dongle, use the following driver path for either 32-bit or 64-bit 
machines:

<Z8051 Installation>\Z8051_<version_number>\device drivers\OCD USB\OCD I

– On OCD II dongle, use the following driver path for either 32-bit or 64-bit 
machines:

<Z8051 Installation>\Z8051_<version_number>\device drivers\OCD USB\OCD II

Figure 3. The Install Device Driver Dialog, Windows 7

IMPORTANT NOTE: If you should encounter the scenarios presented in Figures 7 or 8, right-click your 
mouse on ZILOG OCD II I/F (highlighted in Figure 7) or Unknown device (highlighted in Figure 8) and 
select Update Driver Software... 
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Figure 4. The Browse For Driver Dialog
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4. When Windows prompts you whether to install or not install, as shown in Figure 5, 
click Install and wait until the installation is completed.

Figure 5. The Would You Like to Install Dialog
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5. When the installation is complete, the screen shown in Figure 6 will appear. Click 
Close to exit the OCD II driver installation.

On some installations, the Found New Hardware screen shown in Figure 6 may also dis-
play the text string, Zilog Z8051 USB OCD - No Firmware. This occurrence is normal 
and can be disregarded.

Figure 6. The Successfully Installed Dialog

Note:
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Figure 7. An Unsuccessful Installation, Scenario 1
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Figure 8. An Unsuccessful Installation, Scenario 2
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6. The OCD I or OCD II driver software has been successfully installed when either of 
the following two conditions occur:

a. If Zilog Z8051 USB OCD I appears in the Device Manager when using the OCD I 
debug tool, as indicated in Figure 9.

b. If Zilog Z8051 USB OCD II appears in the Device Manager when using the 
OCD II debug tool, as indicated in Figure 10.

Figure 9. The Device Manager Dialog for the OCD I Installation
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Figure 10. The Device Manager Dialog for the OCD II Installation
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Understanding the OCD Menu Functions

This section describes the operation of the File, View, Emulation, Break/Configure, Test, 
and Window menus.

File Menu

The File menu enables you to open files required for viewing. The OCD II File menu is 
shown in Figure 11.

Emulation Menu

The Emulation menu, shown in Figure 12, lists the controls for starting or stopping an 
emulation routine. Use the Emulation menu to control the flow of code execution for 
debugging purposes.

Figure 11. The OCD II File Menu
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The remainder of this section describes the features of the Emulation menu.

Load Hex

This Emulation menu selection downloads your hex file to the target device; simply click 
the Download button in the Hex file download dialog box. An example is shown in 
Figure 70 on page 66.

To load a hex file to the target MCU, see the procedure described in Appendix C on 
page 65.

Reset and Run

This menu selection starts an emulation from the 0000h address upon a reset of the target 
MCU, and functions in a manner similar to a Power-On Reset. Emulation continues until a 
breakpoint occurs or the user stops the emulation process. The Reset and Run menu is dis-
abled (greyed out) in the Emulation menu during emulation.

Run From

The Run From menu selection starts emulation from a user-specified address, and is used 
to debug each software module. The user is prompted to enter an emulation start address, 
as follows:

Figure 12. The OCD II Emulation Menu

Note:
UM027001-0215  Understanding the OCD Menu Functions



Z8051 On-Chip Debugger II
User Manual

15
• Using LINEAR ADDRESS Mode, enter a 20-bit address directly.

• Using BANKED ADDRESS Mode, enter 4 bits of bank and 16 bits of address. Each 
bank size is smaller than or equal to 64 KB.

The Run From function is disabled (greyed out) in the Emulation menu during emulation.

Run Continue

The Run Continue function begins emulation from the current address, which can be char-
acterized as:

• The last known (stopped) address that was held in the Program Counter from a previ-
ous emulation session

• The point at which a break occurs, such that:

– If a break occurs before the breakpoint, the current address is the PC breakpoint 
address

– If a break occurs after the breakpoint, the current address is the next execution 
address of the PC breakpoint address

• If the target MCU was reset, the reset address is 0000h.

The Run Continue function is disabled (greyed out) in the Emulation menu during emula-
tion.

Step

The Step function is used to debug each instruction flow and process one step at a time; 
the target MCU program flow will execute only one instruction at a time, then halt.

If the MCU receives a CALL instruction, it executes a Step run into the subroutine. If 
MCU is in STOP Mode, the Step run is ignored. The Step function is disabled (greyed out) 
in the Emulation menu during emulation.

Step Over

The Step Over function is used to check main program flow when each subroutine had 
been tested already. This function is similar to the Step function, with the exception of its 
subroutine call. If the MCU receives a CALL instruction, the debugger assumes the CALL 
and its subroutine to be one instruction, even if the subroutines are nested.

If the Step Over function reaches a PC breakpoint condition, emulation is halted. This 
function is disabled (greyed out) in the Emulation menu during emulation.
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Step Auto

Using the Step Auto function, a step run is executed every 100 ms; execution will continue 
unless the user halts it. This function is disabled (greyed out) in the Emulation menu dur-
ing emulation.

Stop

Using the Stop function, emulation is halted immediately, even if the MCU is in STOP 
Mode. This function is disabled (greyed out) in the Emulation menu during emulation.

Apply Reset

The Apply Reset function releases a hardware reset signal to the target MCU, which is 
then reinitialized. Emulation is not halted when the MCU is emulating; however, this 
function has no effect when the target MCU is idle. The Apply Reset function is enabled in 
the Emulation menu whether an emulation is running or is idle.

Break/Configure Menu

The Break/Configure menu, shown in Figure 13, lists PC breakpoint control, device con-
figuration and hardware test functions.

Figure 13. The OCD II Break/Configure Menu
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Clear ALL Break

The Clear ALL Break function immediately clears all PC breakpoints. This menu is dis-
abled (greyed out) in the Break/Configure menu during emulation.

Set Data Break

This menu selection lets you add, remove, or change a data break (also called a break-
point). See Figure 14.

Break BEFORE (AFTER)

The Break BEFORE (AFTER) function prompts the user to select a PC breakpoint event 
either before or after execution. If a break after execution is desired, select Break 
BEFORE (AFTER) exec. from the Break/Configure menu until a checkmark appears 
beside the Break AFTER exec. selection. Make this selection again to remove this check-
mark if a break before execution is desired.

Selecting Break before execution causes a PC breakpoint when the PC reaches the PC 
breakpoint address; however, a PC breakpoint position will not be executed, as illustrated 
in the timing diagram shown in Figure 15.

Figure 14. The Add/Remove/Change Data Break Dialog
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Selecting break after execution causes a PC breakpoint to occur when the PC reaches the 
PC breakpoint address, and a PC breakpoint position is executed, as illustrated in the tim-
ing diagram shown in Figure 16.

Figure 15. Break BEFORE Timing Diagram

Figure 16. Break AFTER Timing Diagram
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This Break BEFORE (AFTER) function is disabled (greyed out) in the Break/Configure 
menu during emulation.

Emulation Time Measuring

This menu, which works only for OCD II devices, changes the emulation time measuring 
option.

Clear Emulation Time

This menu, which works only for OCD II devices, clears the most recent emulation time 
and execution clock information.

Step Run Option

Selecting the Step run option function from the Break/Configure menu prompts the user to 
decide to step run to either of the SOURCE or OPCODE levels.

Peripheral Control

Selecting the Peripheral Control function from the Break/Configure menu prompts the 
user to determine whether the target MCU’s internal peripheral functions should continue 
to operate or remain idle, as shown in Figure 18. These peripherals are always running 
during emulation by default.

Figure 17. Step Run Option Dialog
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The purpose of the Peripheral Control function is to tell the OCD II whether the peripher-
als should be stopped or continuously run during Break (Debug) Mode. All peripherals, 
including the PLL and ADC functions, will be stopped when selecting Stopped concur-
rently. The Peripheral Control menu selection is disabled (greyed out) in the Break/Con-
figure menu during emulation.

The Peripheral Control function does not control each peripheral individually.

Chip Configuration

The Chip Configuration function is used to configure the target MCU’s I/O pin function, 
oscillation method, code protection, etc. Each device series features different configura-
tions. If a configuration changes, the user must turn off power to the target MCU, then 
power it on again. As a result, configurations can be influenced when power rises to oper-
ational voltage.

The Configuration dialog box shown in Figure 19 offers an example configuration for the 
Z51F0420 device.

Figure 18. The Peripheral Control Dialog

Note:
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The Chip Configuration menu selection is disabled (greyed out) in the Break/Configure 
menu during emulation.

Clock Frequency (FAKE)

The OCD I interface does not support measuring emulation time. OCD II does support it, 
but the RTIME pin must first be connected. This clock frequency is FAKE, in that it is not 
the real emulation clock. This value will be used to calculate the emulation time from the 
device’s clock count. If you have connected with OCD II and RTIME, this value will be 
ignored because the debugger can get the real emulation time.

Change OCD Series

To change the target series between OCD I and OCD II, select this option from the Break/
Configure menu.

View Menu

This section describes the components of the OCD II View menu.

Figure 19. Z51F0420 MCU Configuration Example
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Dockable Windows

The View menu, shown in Figure 20, supports the opening of child windows. If Child 
View is checked, the selected child view will be shown. The Debugger offers the follow-
ing nine types of child windows.

• Output

• Diasm View

• Code View

• Xdata View

• Iram View

• Sfr View

• Registers

• Global Variable

• Local Variable

Each of the View menu’s functions are described in this section.

Figure 20. The OCD II View Menu
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Customize

The Customize... selection offers users the flexibility to modify the Command, Toolbar, 
Keyboard, and Menu options in the debugger environment GUI.

Status Bar

This menu selection displays or hides the status bar, which is located at the bottom of the 
debugger frame. The Status bar displays information about the current state of the debug-
ger.

Caption Bar

This menu selection displays or hides the caption bar, which is located at the bottom of the 
tool bars. The Caption bar displays the device name that is associated to either the OCD I 
or OCD II dongle hardware.

Application Look

This selection changes the visual style of the debugger GUI.

Registers

This menu selection opens a window that displays the Z8051 Series’ basic registers. If this 
window is already open, selecting the Registers option will cause this window to disap-
pear from the debugger frame. See Figure 21.
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The Registers menu selection is disabled (greyed out) in the View menu during emulation.

Disasm View

This menu selection opens a window which displays the memory spaces containing disas-
sembled code. If this window is already open, selecting Disasm View from the View 
menu will cause this window to disappear from the debugger frame. See the example in 
Figure 22.

Figure 21. The Registers Dialog
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The Disasm View menu selection is disabled (greyed out) in the View menu during emula-
tion.

Code View

This menu selection opens a window which displays the contents of code memory in a 
dumped format. If this window is already open, selecting Code View from the View menu 
will cause this window to disappear from the debugger frame. See the example in 
Figure 23.

Figure 22. The Disasm View Dialog
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The Code View menu selection is disabled (greyed out) in the View menu during emula-
tion.

Xdata View

This menu selection opens a window which displays the contents of Xdata memory in a 
dumped format. The term Xdata refers to the external data memory contained in Z8051 
Series devices. If this window is already open, selecting Xdata View from the View menu 
will cause this window to disappear from the debugger frame. See the example in 
Figure 24.

Figure 23. The Code View Dialog
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The Xdata View menu selection is disabled (greyed out) in the View menu during emula-
tion.

Iram View

This menu selection opens a window which displays the contents of Iram memory in a 
dumped format. The term Iram refers to the internal data memory contained in Z8051 
Series devices. If this window is already open, selecting Iram View from the View menu 
will cause this window to disappear from the debugger frame. See the example in 
Figure 25.

Figure 24. The Xdata View Dialog
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The Iram View menu selection is disabled (greyed out) in the View menu during emula-
tion.

Sfr View

This menu selection opens a window which displays the contents of the Sfr peripherals in 
a dumped format. The term Sfr refers to the special function registers contained in Z8051 
Series devices. If this window is already open, selecting Sfr View from the View menu 
will cause this window to disappear from the debugger frame. See the example in 
Figure 26.

Figure 25. The Iram View Dialog
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The Sfr View menu selection is disabled (greyed out) in the View menu during emulation.

Global var.

This menu selection opens a window that displays global variables. If this window is 
already open, selecting Global var. from the View menu will cause this window to disap-
pear from the debugger frame. See the example in Figure 27.

The Global var. menu selection is disabled (greyed out) in the View menu during emula-
tion.

Figure 26. The Sfr View Dialog

Figure 27. The Global Variables Dialog
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Local var.

This menu selection opens a window that displays local variables. If this window is 
already open, selecting Local var. from the View menu will cause this window to disap-
pear from the debugger frame. See the example in Figure 28.

The Local var. menu selection is disabled (greyed out) in the View menu during emula-
tion.

Window Menu

The Window menu, shown in Figure 29, can be used to modify the arrangement of child 
windows or to directly select a child window.

Figure 28. The Local Function Dialog

Figure 29. The OCD II Window Menu
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Split

This menu selection splits the view of the text file windows, as shown in Figure 30. You 
can move or remove these split windows by dragging your mouse.

Figure 30. Split Windows
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Child Windows

Child windows are secondary windows that are displayed within the main OCD II window.

Registers Window

The Registers window allows users to edit the contents of the Z8051 Series registers. 
Figure 31 shows an example Registers window.

Edit

Register values can be changed in the Edit window. New register values are downloaded 
to the target MCU upon clicking the Modify button.

In Figure 32, the current register bank is highlighted in the red area. Users can change reg-
ister banks by selecting or deselecting any of the registers in this current register bank.

Figure 31. Using the Registers Function, #1 of 6
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In Figure 33, the R0–R7 registers are highlighted in the red area. These registers map to 
the same area as Iram addresses in the range 00h–1Fh. Users can change these values by 
entering 8-bit hexadecimal formats.

Figure 32. Using the Registers Function, #2 of 6
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In Figure 34, the red area highlights the Program Status Word (PSW), in which bit units 
can be changed.

Figure 33. Using the Registers Function, #3 of 6

Figure 34. Using the Registers Function, #4 of 6
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In Figure 35, the red area highlights the Accumulator (ACC), the B Register (B) and the 
Stack Pointer (SP) registers. Enter a number in n 8-bit hexadecimal format to change any 
of these values.

In Figure 36, the red area highlights the DPTR Register which displays, and can be edited 
by, entering numbers in the 16-bit hexadecimal format. If the target MCU features more 
than two DPTRs, the DPTR field in this dialog shows the currently selected register. If 
each DPTR resides at a different address, Zilog recommends using the Sfr window 
instead.

Figure 35. Using the Registers Function, #5 of 6
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Code Disassemble View

The Code Disassemble view displays the contents of code memory by using a disassemble 
format. All operand values must be entered in hexadecimal format. Figure 37 shows an 
example Code Disassembler view.

Figure 36. Using the Registers Function, #6 of 6
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If map/symbol files are already loaded, the affected source lines are highlighted by red 
asterisks (*), as shown in Figure 38. Double-click any of these highlighted boxes to open 
its source file and move to the appropriate address line.

Figure 37. Using the Code Disassembler Function, #1 of 3
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Line Assemble

The Line Assemble function supports a line assembly function in which users can change 
the code space with assembly language. This function can directly change the target MCU 
code space, but it does not change the source program file.

With your mouse, move the cursor to a line that you wish to change, and double-click its 
Mnemonic field to open an edit field for the contents of that line, as shown in Figure 39. 
Change the contents of the line by entering an instruction, operand, etc., in hexadecimal 
format.

Figure 38. Using the Code Disassembler Function, #2 of 3
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PC Break Toggle

The target MCU’s internal Program Counter (PC), sets or clears all PC breakpoint settings. 
The PC breakpoint count differs in each device in the Z8051 Series; normally, eight break-
points can be set. In Figure 40, the blue line represents a program counter breakpoint in 
the line, and the grey line represents the current program counter.

Figure 39. Using the Code Assembler Function, #3 of 3
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To set or clear a PC breakpoint, set your cursor on a selected line and double-click the 
mouse’s left button.

Before you set a breakpoint on the Disasm View, a red asterisk (*) must be displayed adja-
cent to the Addr field that indicates the valid lines where you can set a breakpoint. Select 
Load Hex to download the hex file to the MCU. Select Reset & Go → Break to see the red 
asterisk (*) where you can set a breakpoint.

Code Dump View

Code dump views display each 8-bit segment of code memory in the hexadecimal format 
and supports the editing of this data. Each 256-byte page resides at an address in the range 
xx00–xxFFh, in which xx is the number of the page.

Figure 40. Using the PC Break Toggle Function

Note:
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The upper side of the Code Dump window displays the address of the current cursor posi-
tion and the checksum of the current page. The current page number is displayed as a 
watermark in the center of this window. In Figure 41, for example, the page number is 00.

Edit

Users can change data values in the Code Dump window at any time, except during emu-
lation. The editing method is quite simple; just place the cursor where you wish to make 
an edit, and write a new character pair in hexadecimal format. The color of the character 
pair background will change from grey to peach to indicate that the change was made, as 
highlighted in Figure 42.

Figure 41. Using the Code Dump Function, #1 of 2
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If you wish to cancel your inputs, press the Escape (Esc) key. Press the Enter key to save 
your changes, and note that the red color of your changed character pair has changed back 
to black.

Bank

The devices in the Z8051 Series use a linear addressing method, and display page units in 
the 64 KB range. To overcome this 64 KB limit, the user can employ banked addresses, in 
which a bank is the upper 4 bits of a 20-bit address.

Figure 42. Using the Code Dump Function, #2 of 2
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Move

Click the Move button  to view memory locations in any 16-bit segments within the 
0000h–FFFFh address range in the Code Dump window or edit these memory locations 
by entering an address in hexadecimal format. See the example Input dialog in Figure 43.

Pattern Load

Click the Pattern Load button to display the Pattern Load dialog, in which you can 
load a data pattern or code hex file to the code space; see Figure 44.

Alternatively, users can download code by choosing Load Hex from the File menu. How-
ever, this method is used to load user-specified data patterns only; it does not clear the 
entire code space. A data pattern can be either a small code segment or complete program 
code.

Figure 43. The Code Dump Function’s Goto/Input Dialog

Figure 44. The Code Dump Function’s Pattern Load Dialog
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Pattern Save

Click the Pattern Save button to display the Pattern Save dialog, in which you can 
save a code space as a pattern file; see the example in Figure 45.

Pattern Fill

Click the Pattern Fill button to display the Pattern Fill dialog, in which you can write 
a common value in all code memory spaces in a specified address range; see the example 
in Figure 46.

Xdata Dump View

The Xdata Dump view displays each 8-bit segment of code memory in the hexadecimal 
format and supports the editing of this data. Each 256-byte page resides at an address in 
the range xx00–xxFFh, in which xx is the number of the page. 

Figure 45. The Code Dump Function’s Pattern Save Dialog

Figure 46. The Code Dump Function’s Pattern Fill Dialog
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The upper side of the Xdata Dump view displays the address of the current cursor position 
and the checksum of the current page. The current page number is displayed as a water-
mark in the center of this window. In Figure 47, for example, the page number is 00.

Edit

Users can change data values in the XData Dump View at any time, except during emula-
tion. The editing method is quite simple; just place the cursor where you wish to make an 
edit, and write a new character pair in hexadecimal format. The color of the character pair 
background will change from grey to peach to indicate that the change was made, as high-
lighted in Figure 48.

Figure 47. Using the Xdata Dump Function, #1 of 2
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Bank

The devices in the Z8051 Series use a linear addressing method, and display page units in 
the 64 KB range. To overcome this 64 KB limit, the user can employ banked addresses, in 
which a bank is the upper 4 bits of a 20-bit address.

Move

Click the Move button to view memory locations in any 16-bit segments within the 
0000h–FFFFh address range in the Xdata Dump window or edit these memory locations 
by entering an address in hexadecimal format. See the example in Figure 49.

Figure 48. Using the Xdata Dump Function, #2 of 2
UM027001-0215  Child Windows



Z8051 On-Chip Debugger II
User Manual

47
Pattern Load

Click the Pattern Load button to display the Pattern Load dialog, in which you can 
load a data pattern or code hex file to the Xdata area. However, this command does not 
clear the Xdata area; see Figure 50.

Pattern Save

Click the Pattern Save button to display the Pattern Save dialog, in which you can 
save the Xdata area as a pattern file; see Figure 51.

Figure 49. The Xdata Dump Function’s Move/Input Dialog

Figure 50. The Xdata Dump Function’s Pattern Load Dialog
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Pattern Fill

Click the Pattern Fill button to display the Pattern Fill dialog, in which you can write 
a common value in all Xdata memory spaces in a specified address range; see the example 
in Figure 52.

Iram Dump View

The Iram Dump view displays each 8-bit segment of code memory in the hexadecimal for-
mat and supports the editing of this data. Each 256-byte page resides at an address in the 
range xx00–xxFFh, in which xx is the number of the page.

The upper side of the Iram Dump window displays the address of the current cursor posi-
tion and the checksum of the current page.

Figure 53 also shows Iram addresses in the range 00h–7Fh, which represent the direct 
area; the characters representing these addresses are colored black.

Figure 51. The Xdata Dump Function’s Pattern Save Dialog

Figure 52. The Xdata Dump Function’s Pattern Fill Dialog
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To learn more about direct and indirect memory areas, please refer to the product specifi-
cation for your particular Z8051 device.

Edit

Users can change data values in the Iram Dump view at any time, except during emula-
tion. The editing method is quite simple; just place the cursor where you wish to make an 
edit, and write a new character pair in hexadecimal format. The color of the character pair 
background will change from grey to peach to indicate that the change was made, as high-
lighted in Figure 54.

Figure 53. Using the Iram Dump Function, #1 of 2
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If you wish to cancel your inputs, press the Escape (Esc) key. Press the Enter key to save 
your changes, and note that the red color of your changed character pair has changed back 
to black.

Sfr Dump View

The Special Function Register (Sfr) Dump view displays each 8-bit segment of code mem-
ory in the hexadecimal format and supports the editing of this data. The upper side of the 
Sfr Dump view displays the address of the current cursor position and the checksum of the 
current page. 

Figure 55 shows Sfr addresses in the range 80h–FFh, which represent the direct area of 
Iram.

Figure 54. Using the Iram Dump Function, #2 of 2
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The special function registers differ in each Z8051 Series device. To learn more about spe-
cial function registers, please refer to the product specification for your particular Z8051 
device.

Edit

Users can change data values in the Sfr Dump view at any time, except during emulation. 
The editing method is quite simple; just place the cursor where you wish to make an edit, 
and write a new character pair in hexadecimal format. The color of the character pair 
background will change from white to peach to indicate that the change was made, as 
highlighted in Figure 56.

Figure 55. Using the Sfr Dump Function, #1 of 3

Figure 56. Using the Sfr Dump Function, #2 of 3
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If you wish to cancel your inputs, press the Escape (Esc) key. Press the Enter key to save 
your changes, and note that the peach color of your changed character pair background has 
changed back to white.

Refresh

The Sfr area includes static registers such as a stack pointer, an accumulator, etc. However, 
most SFRs are dynamic registers such as timers, I/Os, etc. Clicking the Refresh button 
(highlighted in Figure 57) redisplays all current data.

Global Variable

The Global var. displays and supports the modification of global variables within the 
user’s C language-based source program. Each variable is located within the Code, Xdata, 
Iram, Sfr dump spaces. If users could easily determine a variable’s location, they could 
edit the variable directly. However, finding a global variable across these many memory 
dump spaces is often perceived to be a tedious process.

The Global variable alleviates this problem by employing a map/symbol file; see 
Figure 58.

Figure 57. Using the SFRDump Function, #3 of 3
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Add Variable

Clicking the Add Variable button displays the Global Variable Add/Remove dialog, 
in which you can add a global variable to the Global display list, shown in Figure 59.

Figure 58. The Global Function’s Global Variables Dialog
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Remove Symbol

Clicking the Remove Symbol button removes a global variable from the Watch 
Global display list.

Edit

Users can change data values in the Global variable at any time, except during emulation. 
This editing method is quite simple; just place the cursor where you wish to make an edit, 
and double-click the left button on your mouse to display a pop-up dialog in which you 
can change the data and click the Modify pop-up button to incorporate the change, as 
shown in Figure 60.

Figure 59. Adding A Global Variable
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Local Variable

The Local variable displays and supports the modification of local variables within the 
user’s C language-based source program. Each variable is located within the Code, Xdata, 
Iram, Sfr dump spaces. 

Much like the issue with finding global variables, users could edit these local variables 
directly if finding them was not so tedious. The Local variable, shown in Figure 61, allevi-
ates this problem by employing a map/symbol file, as described in the previous section.

Figure 60. Editing A Global Symbol

Figure 61. The Local Function Dialog
UM027001-0215  Child Windows



Z8051 On-Chip Debugger II
User Manual

56
Edit

Users can change data values in the Local variable at any time, except during emulation. 
This editing method is quite simple; just place the cursor where you wish to make an edit, 
and double-click the left button on your mouse to display a pop-up dialog in which you 
can change the data and click the Modify pop-up button to incorporate the change, as 
shown in Figure 62.

Add or Remove Symbol

Locals variables are dynamic; therefore, adding or removing a symbol will depend on 
each program module.

In the Debugger, the user can check the current C module and find its local variables auto-
matically so that the user is not required to add or remove the symbol.

Figure 63 shows an example C source program module. The current program counter is 
located in the delay(UINT uCnt) function module (highlighted in the upper half of the 
figure), and the Local Variable window displays the name of the module and its variable 
(highlighted in the lower half of the figure).

Figure 62. Editing A Local Symbol
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Figure 63. Example Local Function, #1 of 2
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If program flow is changed to another module, then the Local Variable list will be 
changed, as shown in Figure 64.

Figure 64. Example Local Function, #2 of 2
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Appendix A. OCD Driver Installation on 
Windows Vista Systems

The driver programs for the Z8051 On-Chip Debugger II are copied to the development 
PC during the software and documentation installation. In the following procedure for PCs 
running Windows Vista 32- and 64-bit operating systems, ensure that the target side of the 
OCD will remain unconnected while you install these drivers. 

1. Connect the OCD II hardware to the USB port of your PC by connecting the A (male) 
end of one of the two USB A (male)-to-Mini-B cables with the development PC’s 
USB port. Connect the Mini-B end to the OCD II device.

2. After the PC detects the new hardware, it will display the Found New Hardware Wiz-
ard dialog box, shown in Figure 65. Click Locate and install driver software (rec-
ommended). 

3. Depending on your development PC’s User Account Control settings, Windows may 
ask for permission to continue the installation. Click Continue.

Figure 65. Found New Hardware Dialog, Windows Vista
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4. When the Insert the Disc dialog appears, as shown in Figure 66, select I don’t have 
the disc. Show me other options. Click the Next button to display the dialog that 
follows, which is shown in Figure 67.

Figure 66. Install Device Driver Dialog, Windows Vista
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5. Return to page 4 and follow Steps 3 through 6.

Figure 67. Couldn’t Find Driver Dialog, Windows Vista
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Appendix B. OCD Driver Installation on 
Windows XP Systems

The driver programs for the Z8051 On-Chip Debugger II are copied during the software 
and documentation installation. On Windows XP systems, ensure that the target side of the 
OCD will remain unconnected while you install these drivers. It is important that you 
observe the following procedure; do not skip ahead until the OCD drivers are installed.

1. Connect the OCD hardware to the USB port of your PC by connecting the A-Male end 
of one of the two USB A (male)-to-Mini-B cables with the host PC’s USB port, and 
connect the Mini-B end to the OCD device.

2. After the PC detects the new hardware, it will display the Found New Hardware Wiz-
ard dialog box, shown in Figure 68. Select Install from a list or specific location 
(Advanced); then click Next. 

Figure 68. The Found New Hardware Wizard Welcome Screen
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3. The next dialog box, shown in Figure 69, prompts you to enter a path or navigate to 
the directory in which the .inf file was installed. Depending on the type of computer 
you use (32- bit or 64-bit), use the Browse button to navigate to one of the following 
paths and click the Next button, leaving all other selections at their default settings.

– On OCD I dongle, use the following driver path for either 32-bit or 64-bit 
machines:

<Z8051 Installation>\Z8051_<version_number>\device drivers\OCD USB\OCD I

– On OCD II dongle, use the following driver path for either 32-bit or 64-bit 
machines:

<Z8051 Installation>\Z8051_<version_number>\device drivers\OCD USB\OCD II

On some installations, the Found New Hardware screen shown in Figure 68 may also dis-
play the text string, Zilog Z8051 USB OCD - No Firmware. This occurrence is normal 
and can be disregarded.

Note:
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4. When Windows prompts you whether to continue the installation or stop, click the 
Continue Anyway button and wait until the installation is completed (Windows may 
prompt you more than once). When the installation is complete, click Finish.

Figure 69. The Found New Hardware Wizard’s Browse Screen
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Appendix C. Load Hex Procedure

Observe the following procedure to load a user hex code file to the target MCU’s code 
space.

1. Run the Z8051 OCD II software. From the Start menu, navigate to All Programs → 
Zilog Z8051 SW and Docs 2.2 → Zilog Z8051 OCD I and II V1.0. 

You can download the OCD II Software Z8051 Software and Documentation v2.2 for free 
from the Zilog Store.

2. From the Emulation menu, select Load Hex. The Hex File Download dialog box 
appears, as shown in Figure 70.

Note:
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Figure 70. The Hex File Download Dialog
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3. In the Hex File Download dialog, click the Browse button to display the Open dialog 
shown in Figure 71.

4. In the Open dialog, browse to and select the hex file that you wish to load into the 
memory space of the target MCU, then click the Open button to display this hex file 
in the Hex File Download dialog.

5. Click the Download button. The Configuration dialog will appear, as shown in 
Figure 72.

Figure 71. The Open Dialog
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6. In this Configuration dialog, click the Write button to complete the configuration of 
the target MCU’s Flash memory.

Figure 72. The Configuration Dialog
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Customer Support

To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at http://sup-
port.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base or consider par-
ticipating in the Zilog Forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com.
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